WILLKOMMEN BEI NETSUPPORT DNA

Benutzermanagement * Hardwareinventarisierung * Softwareinventarisierung * Anwendungsmetering * Internet Metering * Softwareverteilung * Fernsteuerung

DNA - Dynamic Network Administration.

Für viele Unternehmen stellt die Hard- und Softwareausstattung proportional den größten Posten ihrer IT-Ausgaben dar. Groß- und Kleinunternehmen sind auf ihre Hard- und Software, Netzwerke, Systeme und Datenbanken angewiesen, um konkurrenzfähig und effizient zu bleiben.

Bei einem so hohen Investitionsniveau ist es daher klar, dass diese IT-Anlagegüter richtig verwaltet und gewartet werden müssen, um sicherzustellen, dass sie verfügbar sind und richtig funktionieren, wenn man sie am meisten braucht. Gleichzeitig ist es auch wichtig, über exakte Inventarisierungsinformationen zu verfügen, um festzustellen, wie viele Benutzer innerhalb der Organisation tatsächlich bestimmte Applikationen verwenden. Eine Organisation, die die Entwicklung ihrer Anlagegüter besonders gut verfolgt, wird sich ihrer Infrastrukturbedürfnisse bewusst und weiß genau, wann sich IT-Lösungen effizient einsetzen lassen.

Dies hilft nicht nur, Überlizenzierung zu vermeiden und damit das Softwarebudget zu begrenzen, sondern die proaktive Anlageverwaltung sorgt auch für Konformität mit Software-Lizenzverträgen und genauere Budgetprognosen.

NetSupport DNA ermöglicht die zentrale Verwaltung der PCs in Ihrem Unternehmen auf sichere, koordinierte und effiziente Weise, kombiniert eine leistungsfähige Hard- und Softwareinventarisierung mit Softwareverteilung, Anwendungsmetering, Internet Metering, Web basiertem Helpdesk und klassenbester Fernsteuerung.

Durch seinen modularen Aufbau erlaubt Ihnen NetSupport DNA, die von Ihrem Unternehmen individuell benötigten Features zusammenzustellen.

NetSupport DNA lässt sich nahtlos in die vorhandene IT-Umgebung integrieren und ist eine der vollkommensten, kostengünstigsten Netzwerkmanagement- und Helpdesklösungen, die derzeit auf dem Markt verfügbar sind. NetSupport DNA bietet einen bisher unerreichten ROI, während es die Total Cost of Ownership drastisch reduziert

DNA FEATURES:

HARDWAREINVENTARISIERUNG - SOFTWAREINVENTARISIERUNG - ANWENDUNGSMETERING

INTERNET METERING - LIZENZVERWALTUNG - SOFTWAREVERTEILUNG

UNTERNEHMENSBERICHTE - WEB BASIERTES HELPDESK* - FERNSTEUERUNG*

*Optionale Komponenten


DNA Packs

NetSupport DNA ist als flexibles Produkt in Modulen erhältlich, damit Sie die speziellen Features auswählen können, die Ihren Bedürfnissen am besten entsprechen.

NetSupport DNA ist in folgenden Packs erhältlich.

 | DNA INVENTORY |  |  | DNA SUITE
MODULE | PACK 1 | PACK 2 | PACK 3 | PACK 4 | PACK 5 | PACK 6
Benutzermanagement |  |  |  |  |  |
Hardwareinventarisierung |  |  |  |  |  |
Softwareinventarisierung |  |  |  |  |  |
Anwendungsmetering |  |  |  |  |  |
Internet Metering |  |  |  |  |  |
Softwareverteilung |  |  |  |  |  |
DNA-Fernsteuerung |  |  |  |  |  |
NetSupport Manager |  |  |  |  |  |

Enthalten

Nicht Enthalten


DNA Key Features

BENUTZERMANAGEMENT

NetSupport DNA bietet eine große Auswahl an Features, um PCs in einem Netzwerk aufzufinden und zu verwalten. DNA speichert nicht nur grundlegende Benutzerdaten (Name, Telefon, usw.), sondern es bietet auch die Möglichkeit zum Speichern detaillierter weiterer Angaben zu Anlagegütern, Leasing und Wartungsdaten. DNA ermöglicht es Ihnen, die von den einzelnen Benutzern einzusammelnden Informationen anzupassen.

Mit NetSupport DNA werden durch einen Mechanismus dynamische Gruppen erstellt. Diese werden zum Hauptverzeichnisbaum hinzugefügt und beinhalten PCs beliebiger Abteilungen. Eine typische Gruppe wäre zum Beispiel "alle PCs mit Windows XP und mehr als 256MB RAM".

Zu weiteren Hilfstools gehören Verbindungsstatistiken, Benutzer suchen, Chat, Messaging und ein leistungsfähiges Abfragetool.

DISCOVERY

NetSupport DNA findet – basierend auf einem vorher festgelegten IP-Adressbereich und unter Verwendung des Windows-Netzwerks – automatisch alle PCs in einem LAN oder WAN auf. Sobald PCs aufgefunden werden, erhalten Sie erste Informationen zum Status des jeweiligen PCs und des DNA Clients (falls bereits installiert).

Durch Verwendung des Discovery Tools können DNA Clients unternehmensweit ferngesteuert installiert werden.

HARDWAREINVENTARISIERUNG

NetSupport DNA verfügt über ein leistungsfähiges Hardwareinventarisierungsmodul, das reichhaltige Informationen über einen spezifischen PC, von CPU und BIOS bis hin zu Arbeitsspeicher und Speicherslots, anzeigt und sogar, welche noch für Erweiterungen verfügbar sind.

Beim Betrachten des gesamten Unternehmens oder einer Abteilung zeigt Ihnen DNA auch einfach und schnell einzelne Kategorien, so z. B. alle PCs gruppiert nach Betriebssystem, CPU-Typ oder Menge des Arbeitsspeichers.

SOFTWAREINVENTARISIERUNG

Dieses Feature bietet Ihnen eine detaillierte Übersicht aller auf einem Client PC gefundenen Anwendungen. Diese Informationen können Sie sich für einen einzelnen PC oder auch für ganze Gruppen anzeigen lassen.

Eingesammelte Daten lassen sich benutzerdefiniert anzeigen, so dass unterschiedliche Versionsnummern einer Anwendung gruppiert und zusammengefasst werden, oder um einen firmenweiten Überblick über Lizenzlimits zu bekommen.

ANWENDUNGSMETERING

DNA findet alle installierten Anwendungen auf einem Client PC und erfasst auch deren Nutzung. Zu den erfassten Details gehören der Start und die Beendung der Anwendung sowie die Nutzungsdauer. Bei Betrachtung der Details auf Abteilungsebene erfolgt eine Zusammenfassung und Auflistung aller Anwendungen nach Nutzungshäufigkeit oder auch nach Nutzungsdauer.

Zusätzlich kann die Anwendungsnutzung auf den Client PCs auf bestimmte Tageszeiten beschränkt werden oder auch für alle Benutzer auf bestimmte PCs.

INTERNET METERING

Ähnlich dem Anwendungsmetering bietet DNA eine detaillierte Zusammenfassung der Aktivitäten auf einem Benutzer PC. In diesem Falle bezüglich der Internet- (oder Intranet-) Aktivitäten. Es werden alle besuchten URL sowie die Verweildauer auf einer Webseite und aller zugehörigen Unterseiten innerhalb einer bestimmten URL festgehalten. DNA liefert sogar eine Schnellverknüpfung zur Betrachtung einer spezifischen URL.

Das Internet Metering bietet auch die Möglichkeit, den Zugriff auf bestimmte URL zu beschränken, je nach zugewiesenem Status (z. B. genehmigt oder beschränkt) oder anhand einer flexiblen Zeitrichtlinie.

BERICHTE

NetSupport DNA bietet Ihnen zwei unterschiedliche "Stile" der Berichterstellung. On Screen-Berichte werden mit unterstützenden Balken- oder Kreisdiagrammen ausgegeben mit der Möglichkeit, in allen Hauptsparten erweiterte Details aufzurufen.

Zusätzlich können druckoptimierte Berichte ausgegeben werden. Die hierfür verwendete Crystal Reports Engine bietet eine große Palette an Managementberichten. Alle Berichte beinhalten die Möglichkeit zum Drucken oder zum Export als PDF-, DOC- oder XLS-Dokument.

SOFTWAREVERTEILUNG

DNA bietet eine Multi Delivery-Option für die Softwareverteilung. Zunächst wird ein zu verteilendes Anwendungspaket erstellt. Dieses kann aus mehreren Dateien und Ordnern mit entsprechenden Aktions-Parametern bestehen, bzw. durch Aufnahme und Scripting einer ablaufenden Installationsroutine inklusive der benötigten Benutzereingaben erzeugt werden, um es anschließend ohne die Notwendigkeit einer Interaktion zu verteilen.

Sobald ein Anwendungspaket erstellt wurde, kann dieses automatisch zur Verteilung auf die Ziel-PCs "gepushed" bzw. zentral veröffentlicht werden. Wenn ein Paket veröffentlicht ist, kann ein Benutzer nachsehen, welche Anwendungen für seinen PC verfügbar sind und diese bei Bedarf installieren.

FERNSTEUERUNG*

DNA Remote Control bietet fortschrittliche Funktionalität für ein effektives Management von entfernten Arbeitsstationen. Beobachten, teilen oder kontrollieren Sie Bildschirm, Maus und Tastatur eines Ziel-PCs, unabhängig von Betriebssystem und Netzwerkprotokoll. Beinhaltet auch vollständige Messaging- und Text Chat-Funktionen, umfassende Sicherheitsoptionen, Multi-Plattform-Unterstützung sowie Desktop-Integration.

Wenn Sie eine noch leistungsfähigere Fernsteuerungslösung benötigen, ist NetSupport Manager (NSM) als zusätzliches Modul erhältlich. Ergänzend zu den obengenannten Features bietet NSM noch Dateitransfers und Dateiverteilung, Hard- und Softwareinventarisierung, Scripting und Zeitplansteuerung und enthält auch ein Gateway, das Verbindungen mit PCs hinter einer Firewall ermöglicht, sowie eine Scanfunktion, mit der sich mehrere entfernte Arbeitsstationen gleichzeitig überwachen lassen.

HELPDESK*

NetSupport DNA Helpdesk ist ein leistungsfähiges, jedoch trotzdem einfach zu bedienendes Modul für das Unternehmenshelpdesk. Das Modul ist entweder einzeln in Kombination mit DNA Inventory erhältlich oder als Teil unserer umfassenden Management Suite DNA. DNA Helpdesk ist eine vollständig Web basierte Lösung, die eine detaillierte Protokollierung und Tracking von Hilfeanfragen ermöglicht.

  • Automatische Zuweisung von Tickets an einen Bediener gemäß einer vordefinierten Kundenrichtlinie, basierend auf dem Problemtyp oder Benutzertyp.

  • Automatische Eskalation eines Tickets basierend auf kundenspezifischen Richtlinien.

  • Strukturierte Notiz-History in einem Ticket mit Quellenidentifizierung (Telefon, E-Mail, usw.) für jeden Eintrag während einer Ticketlaufzeit.

  • Voll überprüfbare History für den jeweiligen Benutzer.

  • Direkte Integration mit DNA Suite Inventory und Abteilungsinformationen.

  • Geradlinige Erstellung einer Lösungsdatenbank zur Verwendung bei nachfolgenden Hilfeanfragen.

  • Vereinfachtes Management der Problemtyp-Definitionen.

  • Erweitertes Sicherheits- und Zugriffskontrollmanagement für Bediener und Benutzer.

* Optionale Komponenten


Systemanforderungen

SERVER

Empfohlene Hardware: Pentium III 500MHz oder besser mit 256MB RAM.

Freier Platz erforderlich: 100 MB+ (je nach Anzahl der unterstützten Clients)

Unterstützte Betriebssysteme: Windows NT, 2000, XP oder 2003 Server.

Unterstützte Datenbanken: Microsoft MSDE, SQL7 oder SQL2000.

TCP/IP-Netzwerk

KONSOLE

Intel* 80486 oder besser. 128MB. Windows-Plattformen höher als NT4.

IE6.0 oder besser

Java Virtual Machine

CLIENT

Intel* 80486 oder besser.

7 MB freier Platz

Win 98, NT oder besser (NT erfordert SP6).

IE5 oder besser

Protokoll: TCP/IP (Winsock 2 unter 98).


Components

NetSupport DNA besteht aus drei Hauptkomponenten:

  • DNA Server

  • DNA Konsole

  • DNA Client

Server

Zur Installation der DNA-Datenbank ist ein verfügbarer SQL Server erforderlich. Der Server liefert die gesamte Funktionalität von NetSupport DNA. Er enthält die Repositories, in denen sich alle gesammelten Daten befinden.

Konsole

Die Konsole ist die Hauptschnittstelle zur Ausführung von Befehlen und wird im Allgemeinen auf dem Computer eines Administrators installiert. Ein Administrator führt einen Befehl aus und die gesammelten Daten werden aus der DNA-Datenbank extrahiert, die sich im Server befindet. Konsolenbenutzer erhalten Administratorrechte. Bei der Installation wird zur Erstellung einer ersten Anmeldung durch einen Konsolenbenutzer aufgefordert, aber je nach Bedarf lassen sich auch zusätzliche Konsolenbenutzer hinzufügen.

Client

Der Client ist der Endbenutzercomputer, auf dem Daten gesammelt werden.


Planen einer Installation

Bevor Sie mit der Installation beginnen, müssen Sie sich überlegen, welche Komponenten benötigt werden. NetSupport DNA besteht aus drei Hauptkomponenten:

Server

Zur Installation der DNA-Datenbank ist ein verfügbarer SQL Server erforderlich. Der Server liefert die gesamte Funktionalität von NetSupport DNA. Er enthält die Repositories, in denen sich alle gesammelten Daten befinden.

Konsole

Die Konsole ist die Hauptschnittstelle zur Ausführung von Befehlen und wird im Allgemeinen auf dem Computer eines Administrators installiert. Ein Administrator führt einen Befehl aus und die gesammelten Daten werden aus der DNA-Datenbank extrahiert, die sich im Server befindet. Konsolenbenutzer erhalten Administratorrechte. Bei der Installation wird zur Erstellung einer ersten Anmeldung durch einen Konsolenbenutzer aufgefordert, aber je nach Bedarf lassen sich auch zusätzliche Konsolenbenutzer hinzufügen.

Client

Der Client ist der Endbenutzercomputer, auf dem Daten gesammelt werden.

DNA-Komponenten lassen sich in den folgenden Kombinationen installieren:

  • Server, Konsole und Client

  • Konsole und Client

  • Nur Konsole

  • Nur Client

Hinweis: Wenn Sie eine vorhandene Version von DNA aktualisieren, finden Sie weitere Informationen in unserer Wissensbasis unter www.netsupportsoftware.com.


Starten der Installation

Legen Sie die NetSupport DNA-CD ein und das Begrüßungsmenü wird eingeblendet.

Wählen Sie die Option “Installation”. Der Installationsassistent von NetSupport DNA führt Sie durch das Installationsverfahren und ermöglicht die rasche Konfiguration der gewünschten DNA-Komponenten.

Der Begrüßungsbildschirm des Setupprogramms wird eingeblendet.

Klicken Sie zur Fortsetzung auf "Weiter". Der DNA-Lizenzvertrag wird eingeblendet.

Nehmen Sie sich bitte die Zeit zum Durchlesen des Vertrags, bevor Sie die Bedingungen akzeptieren.

Features zum Installieren auswählen.


Features auswählen

Beschließen Sie, welche Features/Komponenten von DNA Sie installieren möchten und an welchem Ort sie gespeichert werden sollen. Standardmäßig sind alle ausgewählt.

DNA Workstation Client

Die Clientkomponente muss auf Endbenutzerrechnern in Ihrem ganzen Netzwerk installiert werden. Der Server fragt Clientcomputer in regelmäßigen Abständen ab und sammelt und speichert Systeminformationen in der DNA-Datenbank.

Wenn Sie nur den Client installieren, müssen Sie den Speicherort des Servers, der zur Verbindung mit Clients verwendet wird, eingeben.

DNA-Informationsserver

Den Rechner, auf dem die Serversoftware installiert und die Datenbank gespeichert ist, nennt man den DNA Server.

Es ist ein verfügbarer SQL basierter Server zur Installation der DNA-Datenbank erforderlich. Der Server liefert die gesamte Funktionalität von NetSupport DNA. Er enthält die Repositories, in denen sämtliche gesammelten Daten gespeichert sind.

DNA-Managementkonsole

Die DNA Konsole ist das Hauptprogramm zur Ausführung von Befehlen. Sie fungiert als Benutzerschnittstelle. Ein Administrator führt einen Befehl aus und die gesammelten Daten werden aus der DNA-Datenbank, die sich im Server befindet, extrahiert.

Anwendungs-Packager

Der DNA Anwendungs-Packager ergänzt die Softwareverteilungsfunktion und ist ein Programm, mit dem sich Produktinstaller von "niedriger Komplexität" aufzeichnen und wieder abspielen lassen.

Zielordner

Standardmäßig installiert Setup die Dateien im Ordner C:\Programme\NetSupport DNA\DNA. Um an einem anderen Ort zu installieren, klicken Sie auf "Durchsuchen".


Einrichtung von Server und Konsole

SQL-Datenbanksicherheit

Geben Sie den Namen und die Adresse für Ihren SQL Server ein. Es kann sich dabei um den Lokalcomputer handeln oder auch nicht. Dies ist ein Freiformat-Textfeld, in das Sie entweder die IP-Adresse oder ein namentliches Auftreten des SQL Servers eingeben können.

Wählen Sie die angemessene Überprüfungsmethode, SQL oder Windows NT. Bei SQL müssen Sie den Benutzernamen und das Kennwort Ihrer Master-Datenbank eingeben.

Klicken Sie auf "Weiter".

Geben Sie einen Benutzernamen und ein Kennwort für die DNA-Datenbank ein und klicken Sie auf "Weiter".

Geben Sie den Anmeldenamen und das Kennwort ein, die nach Installation der DNA-Konsole für den Zugriff auf diese verwendet werden sollen. Zusätzliche Anmeldungen für Konsolebediener lassen sich nach der Installation erstellen.

Wählen Sie "Evaluierung" oder geben Sie die von NetSupport gelieferten Lizenzdetails ein. Die bereitgestellte Lizenzdatei ist in einen passenden Ordner zu kopieren. Bei der Lizenznummer wird die Groß-/Kleinschreibung berücksichtigt. Die standardmäßige Evaluierungslizenz für NetSupport DNA ist 30 Tage lang gültig und gestattet maximal 50 Benutzer.

Klicken Sie auf "Weiter".

Es wurden genügend Informationen für den Beginn der Installation geliefert. Wenn Sie die Einstellungen überprüfen möchten, klicken Sie auf "Zurück" oder klicken Sie auf "Weiter", um mit der Installation zu beginnen.

Hinweis: Nach der Installation lassen sich Ihre Datenbank, Konsole oder Lizenzdetails mit einem praktischen Hilfsprogramm aktualisieren. Siehe: Verwendung des DNA-Datenbankassistenten.


Verwendung des DNA Datenbank-Assistenten

Der DNA Datenbank-Assistent ist ein praktisches Dienstprogramm, das Sie nach der Installation ausführen können, wenn Sie Ihre DNA-Einstellungen ändern möchten.

Mit dem Assistenten können Sie die DNA-Datenbank erstellen, Konsolenbenutzer hinzufügen und Lizenzdetails aktualisieren.

Während der Installation wird der DNA Datenbank-Assistent in den Serverordner des DNA-Programmverzeichnisses kopiert. Standard: c:\Programme\Netsupport DNA\DNA\Server\DNADBWizard.

Hinweis: Damit die Änderungen in Kraft treten, muss der Serverdienst neu gestartet werden.

Installation und Setup der Datenbank zur Verwendung

Setup eines NetSupport DNA-Benutzers für den Zugriff auf die Datenbank

Setup von Administratorbenutzern für den Zugriff auf den DNA-Server

Registrieren einer Lizenz


Client Installer Package

Client Installationsprogramm-Paket

Zusätzlich zur Standardinstallation lässt sich die Clientkomponente auch entfernt (gepushed) auf den gewünschten PCs installieren.

Das Nur Client Installationsprogramm-Paket, das während einer Serverinstallation zum DNA-Programmordner hinzugefügt wird, lässt sich als Netzfreigabe verfügbar machen, so dass Sie den Client an die gewünschten Computer pushen können.

Bei der ersten Installation wird die bei der Eingabe der SQL Serverdetails angegebene Server IP-Adresse an das Paket übergeben und in der Datei DNAClient.ini gespeichert. Hierdurch wird gewährleistet, dass Clients, die das Paket erhalten, wissen, mit welchem Server sie kommunizieren müssen.


Ausführen der Konsole

Nach der Installation können Administratoren (Konsolebenutzer) die DNA Konsole laden und mit dem Abfragen der Datenbank beginnen.

  1. Wählen Sie {Start}{Programme}{NetSupport DNA}{DNA Konsole}.

  2. Das Dialogfeld "Konsolenanmeldung" wird eingeblendet.

  3. Bestätigen Sie, dass die richtige Serveradresse angegeben ist und geben Sie Konsolebenutzernamen und Kennwort ein.

  4. Klicken Sie auf OK.

  5. Der Hauptkonsolebildschirm von NetSupport DNA wird eingeblendet.


Das Konsolefenster

Das Konsolefenster ist die wichtigste Schnittstelle für den Zugriff auf die zahlreichen Optionen von DNA. Mit einer bequemen Strukturansicht können Sie schnell die Daten für einen bestimmten Benutzer oder eine Abteilung einblenden. Das Hauptinformationsfenster enthält Registerkarten für die einzelnen Hauptkomponenten von DNA, was Ihnen die einfache Navigation zwischen den Optionen ermöglicht.

Menüleiste

Die Menüleiste enthält eine Reihe von Dropdownmenüs zum Zugriff auf die verschiedenen Tools, Komponenten und Konfigurationsprogramme.

Die Symbolleiste

Die Symbolleiste enthält Verknüpfungen zu den meisten am häufigsten verwendeten Aufgaben. Sie können spezifische Optionen für die einzelnen Komponenten-Registerkarten hinzufügen, indem Sie {Betrachten}{Symbolleisten} in der Menüleiste auswählen.

Die hierarchische Strukturansicht

In der hierarchischen Strukturansicht sind alle dynamisch gefundenen DNA Clients sowie alle nicht standardmäßigen Hardware. Die Struktur entspricht standardmäßig der Struktur Ihrer Arbeitsgruppe/Domäne, aber Sie können sie an individuelle Bedürfnisse anpassen, z. B. Clients nach geografischem Standort oder nach Abteilung gruppieren.

Ferner lassen sich dynamische Gruppen erstellen, welche die rasche Identifizierung von Clients, die bestimmte Kriterien erfüllen, ermöglichen. Eine typische "dynamische Gruppe" sind z. B. "alle PCs, die unter Windows XP laufen und mehr als 256 MB RAM haben".

Informationsfenster

Im Informationsfenster sind die Daten angezeigt, die für jede der Hauptkomponenten von DNA gesammelt wurden. Zur Vereinfachung der Navigation sind die einzelnen Komponenten durch Funktionsregisterkarten identifiziert, was Ihnen die rasche Bewegung zwischen den Optionen ermöglicht:

Registerkarten "Betrachten", "Fragen" und "Berichte"

Betrachten

Auf den DNA-Bildschirmen finden Sie eine Reihe von Berichtoptionen, unterstützt von Balken- und Tortendiagrammen und Drilldownfähigkeiten.

Fragen
Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Berichte
Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.


Zusätzliche Konsolebenutzer erstellen

Es können zusätzliche Anmeldungen für Konsolebenutzer erstellt werden. Jedem Benutzer werden Administrator- oder Bedienerrechte zugewiesen, was es Ihnen gestattet, die Funktionalität für gewisse Konsolebenutzer einzuschränken.

  1. Wählen Sie {Tools}{Bediener konfigurieren} in der Menüleiste. Das Dialogfeld "Konsolebediener" wird eingeblendet.

  2. Um neue Bedieneranmeldungen zu erstellen und die entsprechenden Rechte zuzuweisen, klicken Sie auf Hinzufügen. Wenn Sie einen vorhandenen Benutzer bearbeiten möchten, wählen Sie seinen Namen und klicken auf Eigenschaften.

  3. Um ein Objekt zu entfernen, wählen Sie seinen Namen und klicken auf "Entfernen".


Client Discovery und Deploy-Tool

Das Discovery und Deploy-Tool dient zur Suche nach PCs in Ihrem Netzwerk, um dann entfernt einen DNA Client an sie verteilen zu können. Nachdem sie gefunden sind, wird ein Schlüssel-PC-Status und DNA Clientstatus (wenn ein solcher installiert ist) angezeigt. Mit diesen Informationen können Sie die Liste problemlos verfeinern und Computer ausschließen, an die Sie nicht verteilen möchten, so dass nur noch die zur Verteilung gewünschten Computer übrig bleiben.

Sie können das Netzwerk basierend auf einem IP-Bereich oder durch Verwendung des vorhandenen Windows-Netzwerks absuchen.

  1. Wählen Sie {Tools}{Client Discovery und Deploy} in der Menüleiste oder klicken Sie auf das Symbol "Client Discovery und Deploy" in der Symbolleiste.

  2. Wählen Sie die Methode zur Suche nach Computern, nach IP-Adresse oder über das Windows Netzwerk.

  3. Klicken Sie auf "Hinzufügen".

  4. Wenn Sie nach IP-Adresse suchen, geben Sie den Adressbereich ein, oder wählen Sie bei Verwendung des Windows-Netzwerks die Netzwerkgruppen.

  5. Klicken Sie auf "OK", um nach übereinstimmenden Computern zu suchen.

  6. Um bei der Identifizierung der PCs zu helfen, die in die Verteilung ein- oder aus ihr ausgeschlossen werden sollen, lässt sich die Liste sortieren, indem Sie auf eine beliebige Spaltenüberschrift klicken.

  7. Sie können die Liste ggf. auch noch weiter verfeinern, indem Sie Computer entfernen, die Sie nicht in die Verteilung einschließen möchten. Zum Beispiel "ungültige" Clients oder solche, bei denen ein aktueller DNA Client als bereits installiert identifiziert wurde. Klicken Sie auf Auswählen und wählen Sie in der Dropdownliste die gewünschte Aufgabe. Klicken Sie auf Ausschließen, um die markierten Elemente zu entfernen.

  8. Wählen Sie aus den übrigen PCs diejenigen aus, an die verteilt werden soll. Um alle Computer einzuschließen, klicken Sie auf Auswählen – Alle Clients oder markieren mit Umschalt-Klick, Strg-Klick individuelle Objekte.

  9. Klicken Sie auf Deploy, wenn Sie fertig sind.

  10. Da es sein kann, dass die PCs zum Zeitpunkt der Verteilung in Betrieb sind, können Sie vor dem Beginn eine Warnung an die Benutzer senden. Klicken Sie auf Start. Das Dialogfeld "Deploy-Optionen" wird eingeblendet.


Abteilung erstellen

Die Strukturansicht lässt sich stark konfigurieren, so dass Sie mit Ihrem DNA-Setup die Struktur Ihrer Organisation widerspiegeln können. Abteilungen können manuell hinzugefügt und Clients wunschgemäß zwischen Abteilungen hin- und herverschoben werden.

  1. Wählen Sie in der Strukturansicht das Unternehmen oder einen vorhandenen Abteilungsnamen.

  2. Klicken Sie mit der rechten Maustaste und wählen Sie "Neu". Oder wählen Sie in der Menüleiste die Optionen {Datei}{Neue Abteilung} oder klicken Sie in der Symbolleiste auf das Symbol "Neue Abteilung".

  3. Das Dialogfeld "Neue Abteilung" wird eingeblendet.

  4. Geben Sie den Abteilungsnamen und eine passende Beschreibung ein und wählen Sie eine Symbolfarbe.

  5. Beschließen Sie durch Wahl des übergeordneten Objekts, auf welcher Ebene der Strukturansicht die Abteilung eingefügt werden soll.

  6. Klicken Sie auf "OK".


Hinzufügen von Clients zu Abteilungen

Beim Installieren eines DNA Clients wird dieser dynamisch zur passenden Domäne in der Konsolestrukturansicht hinzugefügt. Konsolebediener können jedoch die Strukturansicht anpassen, so dass sie zusätzliche Abteilungen enthält, und Clients zwischen diesen Bereichen verschieben.

Ein individueller Client lässt sich verschieben, indem Sie einfach den gewünschten PC mit der Drag&&Drop-Funktion in der Strukturansicht an den gewünschten Ort bewegen. Oder die Benutzerdetails können bearbeitet werden. Klicken Sie mit der rechten Maustaste auf den gewünschten Client in der Strukturansicht, wählen Sie "Benutzerdetails bearbeiten" und aktualisieren Sie das Abteilungsfeld.

Mehrere Clients lassen sich leicht mit der Funktion Zuweisen/Neu zuweisen verschieben.

  1. Klicken Sie in der Strukturansicht mit der rechten Maustaste auf die gewünschte Abteilung. Diejenige, in die oder aus der Sie Clients verschieben möchten.

  2. Wählen Sie "Eigenschaften". Die aktuellen Eigenschaften für die gewählte Abteilung werden angezeigt.

  3. Klicken Sie auf "Zuweisen" oder "Neu zuweisen", je nachdem, ob Sie Client-PCs in die oder aus der Abteilung verschieben möchten.

  4. Wählen Sie aus der Liste der verfügbaren PCs den PC, den Sie verschieben möchten, und klicken Sie auf [image]. Wiederholen Sie den Vorgang für alle weiteren PCs, die Sie verschieben möchten.

  5. Wenn Sie den Client-PC versehentlich verschoben haben, klicken Sie auf [image] , um ihn erneut der ursprünglichen Abteilung zuzuweisen.

  6. Klicken Sie auf "OK", wenn Sie fertig sind.


Dynamische Gruppen

Diese Funktion bietet eine schnelle und einfache Methode zur Gruppierung von Clients aufgrund von spezifischen Bedingungen. Zu typischen Verwendungszwecken gehört die Identifizierung von Benutzern, die abgelaufene Hardware oder Software ausführen.

  1. Klicken Sie in der Strukturansicht mit der rechten Maustaste auf Dynamische Gruppen und wählen Sie "Neu".

    Oder

    Wählen Sie {Datei}{Neue dynamische Gruppe} in der Menüleiste.

    Oder

    Klicken Sie in der Symbolleiste auf das Symbol Neue dynamische Gruppe erstellen.

  2. Geben Sie einen Namen und eine Beschreibung für die neue Gruppe ein.

  3. Wählen Sie alle zutreffenden Optionen:

In der dynamische Gruppen-Strukturansicht der Konsole anzeigen

Wenn es sich hierbei um eine einmalige Suche nach einer bestimmten Gruppe von PCs handelt, können Sie beschließen, die Gruppe nicht zur Strukturansicht hinzuzufügen.

Nach Bedarf aktualisieren

Aktivieren Sie diese Option, wenn Sie möchten, dass neue Client PCs, welche die Kriterien erfüllen, automatisch zu der Gruppe hinzugefügt werden.

Snapshot erstellen - Aktualisierung über den Speicherbefehl im Editor

Statt neue PCs automatisch zu der Gruppe hinzuzufügen, können Sie zu einem bestimmten Zeitpunkt einen Snapshot anfertigen und die Clientliste nach Bedarf aktualisieren. Verwenden Sie hierzu den Speicherbefehl im dynamische Benutzergruppen-Editor.

  4. Klicken Sie auf "OK". Das Dialogfeld für den dynamische Benutzergruppen-Editor wird eingeblendet. Hier können Sie die Bedingung erstellen, die bestimmt, welche Clients für die Gruppe ausgewählt werden.


DNA-Einstellungen

Administratoren/Konsolebediener können auf jede der Hauptfunktionen von DNA auf Unternehmens- oder Abteilungsebene spezielle Einstellungen anwenden. Die Häufigkeit, mit der Inventardaten gesammelt werden, kann zum Beispiel auf individueller Abteilungsebene eingestellt werden, oder Sie können den Zugriff auf gewisse Websites durch bestimmte Abteilungen blockieren.

Um auf das Menü "Einstellungen" zuzugreifen, markieren Sie in der Strukturansicht die Abteilung oder das Unternehmen, auf die/das sich die Einstellungen beziehen, und wählen in der Menüleiste die Optionen {Bearbeiten}{Einstellungen}.

Klicken Sie auf ein Symbol, um Informationen über die betreffende Option zu erhalten:


DNA-Client - Einstellungen

Clientsymbol zeigen

Wenn das DNA-Clientsymbol aktiviert ist, erscheint es auf der Taskleiste am Client PC.

Alle xx Stunden nach Aktualisierungen suchen

Bei jedem Beginn eines DNA Client-Services wird der Server automatisch nach aktualisierten Komponenten abgesucht. Während Clients aktiv sind, können Sie auch die Häufigkeit einstellen, mit der sie den Server abfragen. Wenn Sie zum Beispiel ein großes Netzwerk haben, kann es empfehlenswert sein, dass Clients nur ein- bis zweimal täglich nach Aktualisierungen suchen. Oder wenn andererseits Aktualisierungen verfügbar sind, möchten Sie u. U., dass Clients häufiger nach diesen suchen.

Auf Unterabteilungen anwenden

Wenn Sie diese Option aktivieren, werden alle Clients in der gewählten Abteilung oder dem Unternehmen mit den neuen Einstellungen aktualisiert.

Hinweis: Durch Betätigen der Schaltfläche "Zurücksetzen" werden alle Abteilungseinstellungen gelöscht und die übergeordneten Einstellungen wiederhergestellt.


DNA-Hardwareinventarisierung - Einstellungen

Hardwareinventarisierung aktivieren

Wenn Sie diese Markierung aufheben, wird die Hardwareinventarisierung deaktiviert.

Beim Start ausführen

Wenn diese Option aktiviert ist, beginnt die Hardwareinventarisierung, sobald die Konsole angemeldet wird.

Ausführen alle xx Minuten (Standardeinstellung 10 Minuten)

Die Hardwareinventarisierung lässt sich so konfigurieren, dass sie in angegebenen Zeitabständen ausgeführt wird. Geben Sie die gewünschte Zeitspanne zum Ausführen der Inventarisierung ein.

Auf Unterabteilungen anwenden

Wenn Sie diese Option aktivieren, werden alle Clients in der gewählten Abteilung oder dem Unternehmen mit den neuen Einstellungen aktualisiert.

Hinweis: Durch Betätigen der Schaltfläche "Zurücksetzen" werden alle Abteilungseinstellungen gelöscht und die übergeordneten Einstellungen wiederhergestellt.


DNA Softwareinventarisierung - Einstellungen

Das Inventarisierungstool scannt standardmäßig häufige Speicherorte, z. B. Programmdateien, auf der Suche nach den auf jedem Client PC installierten exe-Dateien. Sie können jedoch die Suche auch auf zusätzliche Ordner und Dateitypen erweitern.

Softwareinventarisierung aktivieren

Wenn Sie diese Markierung aufheben, wird die Softwareinventarisierung deaktiviert.

Beim Start ausführen

Wenn diese Option aktiviert ist, beginnt die Softwareinventarisierung, sobald die Konsole angemeldet wird.

Ausführen alle xx Minuten (Standardeinstellung 10 Minuten)

Die Softwareinventarisierung lässt sich so konfigurieren, dass sie in angegebenen Zeitabständen ausgeführt wird.

Zusätzliche Ordner scannen

Hier können Sie Ordner angeben, die u. U. bei der Kompilierung des Inventars nicht standardmäßig eingeschlossen werden.

Andere Erweiterungen scannen

Geben Sie die Erweiterung aller zusätzlichen Dateitypen, die Sie beim Scannen der Client PCs einschließen möchten, an.

Auf Unterabteilungen anwenden

Wenn Sie diese Option aktivieren, werden alle Clients in der gewählten Abteilung oder dem Unternehmen mit den neuen Einstellungen aktualisiert.

Hinweis: Durch Betätigen der Schaltfläche "Zurücksetzen" werden alle Abteilungseinstellungen gelöscht und die übergeordneten Einstellungen wiederhergestellt.


DNA-Benutzerdetails - Einstellungen

Client- und Inventarinformationen lassen sich über das Dialogfeld "Benutzerdetails" aktualisieren.

Die Standardeinstellungen für das Dialogfeld können folgendermaßen geändert werden:

Benutzerdetails aktivieren

Wenn diese Option nicht markiert ist, ist die Funktion zum Zugriff auf das Dialogfeld "Benutzerdetails" an den Rechnern der Clients deaktiviert. Konsolebediener können das Dialogfeld auf Clientcomputern trotzdem noch öffnen.

Begrüßungsseite zeigen

Das Dialogfeld "Benutzerdetails" umfasst standardmäßig zwei Seiten (Registerkarten), Willkommen und Allgemein. Anwender können zu diesen ggf. benutzerdefinierte Seiten hinzufügen. Heben Sie die Markierung dieses Feldes auf, um die Begrüßungsseite auszublenden.

Begrüßungsnachricht

Wenn die Begrüßungsseite angezeigt ist, können Sie eine benutzerdefinierte Meldung/Eingabeaufforderung hinzufügen.

Schreibschutz für Details aktivieren

Wenn diese Option markiert ist, können Clients die Benutzerdetails betrachten, aber keine Informationen eingeben.

Auf Unterabteilungen anwenden

Wenn Sie diese Option aktivieren, werden alle Clients in der gewählten Abteilung oder dem Unternehmen mit den neuen Einstellungen aktualisiert.

Hinweis: Durch Betätigen der Schaltfläche "Zurücksetzen" werden alle Abteilungseinstellungen gelöscht und die übergeordneten Einstellungen wiederhergestellt.


DNA Softwareverteilung - Einstellungen

Die Einstellungen der Softwareverteilung bestimmen in erster Linie, ob die Paketanforderungsfunktion auf den Clientcomputern verfügbar ist.

Softwareverteilung aktivieren

Wenn diese Option nicht markiert ist, ist die Paketanforderungsfunktion auf den Clientcomputern deaktiviert.

Beim Client nur angebotene Pakete zeigen

Mit der Paketanforderungsfunktion können Clients Pakete installieren, die vom Konsolebediener angeboten wurden. Diese werden in einem Dialogfeld, in dem der Client auswählen kann, aufgelistet. Clients können zwar nur angebotene Pakete installieren, aber durch Deaktivieren dieses Feldes lässt sich eine vollständige Liste der Pakete zur Betrachtung durch die Clients einblenden.

Titel

Sie können im Paketdialogfeld, das auf den Client PCs eingeblendet wird, einen benutzerdefinierten Titel anzeigen.

Auf Unterabteilungen anwenden

Wenn Sie diese Option aktivieren, werden alle Clients in der gewählten Abteilung oder dem Unternehmen mit den neuen Einstellungen aktualisiert.

Hinweis: Durch Betätigen der Schaltfläche "Zurücksetzen" werden alle Abteilungseinstellungen gelöscht und die übergeordneten Einstellungen wiederhergestellt.


Einstellungen für das Internet-Metering von DNA

Mit dem Internet-Metering können Bediener die Internetnutzung der Clients überwachen und einschränken. Sie haben die Möglichkeit, das Metering ein- oder auszuschalten und den Zugriff auf designierte Sites einzuschränken.

Internet-Metering aktivieren

Wenn Sie die Markierung dieses Feldes aufheben, wird das Internet-Metering ausgeschaltet.

Meteringdaten sammeln alle xx Minuten (Standardeinstellung 10 Minuten)

Geben Sie an, wie oft Daten gesammelt werden sollen. Wenn Sie ein großes Netzwerk haben, möchten Sie vielleicht, dass Daten nicht so oft gesammelt werden. Oder Sie können die Häufigkeit von der Regelmäßigkeit, mit der ein Anwender die Informationen überprüft, abhängig machen.

Internetblockierung

Sie können nicht nur die Verwendung des Internets überwachen, sondern Clients auch daran hindern, bestimmte Sites zu besuchen.

Unbeschränkter Zugriff

Clients können zu jeder Tageszeit auf eine beliebige Site zugreifen.

Nur genehmigte Sites

Wenn diese Option aktiviert ist, können Clients nur Sites besuchen, die in der genehmigten Liste aufgeführt sind.

Beschränkte Sites blockieren

Wenn diese Option aktiviert ist, können Clients die Sites in der eingeschränkten Liste nicht besuchen.

Alle Sites blockieren

Wenn diese Option aktiviert ist, können Clients keine Sites besuchen.

Blockierte Sites umleiten zu xxxxxxx

Geben Sie eine URL ein, zu der die Clients umgeleitet werden, wenn sie versuchen, eine blockierte Site zu besuchen.

Auf Unterabteilungen anwenden

Wenn Sie diese Option aktivieren, werden alle Clients in der gewählten Abteilung oder dem Unternehmen mit den neuen Einstellungen aktualisiert.

Hinweis: Durch Betätigen der Schaltfläche "Zurücksetzen" werden alle Abteilungseinstellungen gelöscht und die übergeordneten Einstellungen wiederhergestellt.


Anwendungsmetering von DNA - Einstellungen

Mit dem Anwendungsmetering können Bediener die Anwendungsnutzung der Clients überwachen und einschränken. Sie haben die Möglichkeit, das Metering ein- oder auszuschalten und den Zugriff auf designierte Anwendungen einzuschränken.

Anwendungsmetering aktivieren

Wenn Sie die Markierung dieses Feldes aufheben, wird das Metering ausgeschaltet.

Meteringdaten sammeln alle xx Minuten (Standardeinstellung 10 Minuten)

Geben Sie an, wie oft Daten gesammelt werden sollen. Wenn Sie ein großes Netzwerk haben, möchten Sie vielleicht, dass Daten nicht so oft gesammelt werden. Oder Sie können die Häufigkeit von der Regelmäßigkeit, mit der ein Anwender die Informationen überprüft, abhängig machen.

Anwendungseinschränkungen für das Unternehmen

Klicken Sie auf Einschränkungen, um eine Liste mit genehmigten/eingeschränkten Anwendungen zu erstellen, und wählen Sie, ob die Einschränkungen aktiviert oder deaktiviert werden sollen.

Auf Unterabteilungen anwenden

Wenn Sie diese Option aktivieren, werden alle Clients in der gewählten Abteilung oder dem Unternehmen mit den neuen Einstellungen aktualisiert.

Hinweis: Durch Betätigen der Schaltfläche "Zurücksetzen" werden alle Abteilungseinstellungen gelöscht und die übergeordneten Einstellungen wiederhergestellt.


Benutzerdetails

Für jeden Client können umfassende Benutzer- und Inventarinformationen aufgezeichnet werden. Die Daten lassen sich im Informationsfenster in verschiedenen Formaten betrachten. Und Sie können auf Unternehmens-, Abteilungs- oder dynamischer Gruppenebene Zusammenfassungsstatistiken betrachten.

Clients haben jederzeit die Möglichkeit, ihre Details zu ändern, und Konsolebediener dürfen Updates verlangen. Zusätzlich zu den standardmäßigen Benutzer- und Inventarinformationen lassen sich auch benutzerdefinierte Seiten, die Ihren individuellen Bedürfnissen entsprechen, hinzufügen.

  1. Klicken Sie auf die Registerkarte "Benutzerdetails" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Benutzerdetails}.

Wählen Sie in der hierarchischen Strukturansicht die Ebene, auf der Sie die Informationen betrachten möchten: Unternehmen, Abteilung, dynamische Gruppe oder individueller Client. Es sind nun verschiedene Anzeigeoptionen verfügbar. Unten im linken Fensterbereich sehen Sie drei Registerkarten.

Betrachten

Im Fenster "Benutzerdetails" sehen Sie die Gesamtzahl der DNA Client-Serververbindungen für verschiedene Zeitspannen in Grafik- und Listenformat. Verbindungsstatistiken mit Angabe von Benutzernamen, Abteilung und letzter Verbindung sind für jeden DNA Client aufgeführt und lassen sich für das ganze Unternehmen, eine Abteilung oder eine dynamische Gruppe betrachten.

Wenn ein Client in der Strukturansicht markiert ist, erscheinen die Benutzerdetails für den betreffenden Client im Informationsfenster.

Abfragen

Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Klicken Sie auf [image], um eine neue Abfrage zu erstellen und auf [image] um ein vorhandenes Objekt in der Liste zu bearbeiten.

Berichte

Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.


Benutzerdetails anfordern/bearbeiten

Benutzer und damit verknüpfte Inventardetails lassen sich durch die Clients selbst oder durch Konsolebediener mit den entsprechenden Befugnissen aktualisieren.

Über die Option Benutzerdetails anfordern können Konsolebediener entfernt auf den Client PCs das Dialogfeld "Benutzerdetails" starten.

  1. Während die Registerkarte "Benutzerdetails" ausgewählt ist, markieren Sie einen Client, eine Abteilung oder das Unternehmen in der Strukturansicht.

  2. Klicken Sie mit der rechten Maustaste und wählen Sie "Benutzerdetails anfordern".
    Oder
    Wählen Sie {Benutzerdetails}{Benutzerdetails anfordern} in der Menüleiste.
    Oder
    Klicken Sie auf das Symbol "Details anfordern" in der Symbolleiste.

  3. Auf den gewählten Rechnern wird das Dialogfeld "Benutzerdetails" eingeblendet. Hier können Clients Ihre Informationen ergänzen oder aktualisieren.

Beim Start auf den Client PCs wird standardmäßig eine Begrüßungsseite eingeblendet. Diese kann benutzerdefinierbare Meldungen/Eingabeaufforderungen enthalten oder Sie kann mit der Einstellungsoption für Benutzerdetails deaktiviert werden. Weitere Angaben hierzu finden Sie unter "DNA-Einstellungen" .

Die Option Benutzerdetails bearbeiten lässt sich von Bedienern oder Clients zur Aktualisierung von Informationen verwenden.

Bei der Konsole

Ein Bediener mit entsprechenden Rechten kann die Informationen für einen individuellen Client bearbeiten.

  1. Wählen Sie in der Strukturansicht einen Client aus.

  2. Klicken Sie mit der rechten Maustaste und wählen Sie "Bearbeiten".
    Oder
    Wählen Sie {Benutzerdetails - Benutzerdetails bearbeiten} in der Menüleiste.
    Oder
    Klicken Sie auf das Symbol "Benutzerdetails" in der Symbolleiste.

  3. Das Dialogfeld "Benutzerdetails" wird eingeblendet.

Beim Client
Clients können ihre eigenen Benutzer- und Inventardetails aktualisieren.

  1. Klicken Sie mit der rechten Maustaste auf das Clientsymbol in der Taskleiste und wählen Sie "Benutzerdetails bearbeiten".

  2. Das Dialogfeld "Benutzerdetails" wird eingeblendet.


Angepasste Benutzerdetails

Standardmäßig wird eine Reihe von Benutzer- und Inventarinformationen dynamisch aufgezeichnet. Die Daten lassen sich mit den Optionen "Benutzerdetails anfordern" und "Benutzerdetails bearbeiten" aktualisieren.

Wenn die Standardseiten, "Allgemein" und "Inventar", Ihren Anforderungen nicht vollständig gerecht werden, können Sie zusätzliche angepasste Registerkarten erstellen.

  1. Wählen Sie {Tools}{Angepasste Benutzerdetails} in der Menüleiste.

  2. Der Editor für benutzerdefinierte Felder wird eingeblendet. Hier können Sie eine beliebige Anzahl von angepassten Registerkarten erstellen.

  3. Wählen Sie Neue Registerkarte, um eine neue Seite zu erstellen, oder Registerkarte bearbeiten, um die Eigenschaften eines vorhandenen Objekts zu ändern. Geben Sie einen Namen für die Seite ein.

  4. Entscheiden Sie, ob Informationen auf der neuen Registerkarte beim Betrachten des Fensters "Benutzerdetails" mit dem angemeldeten Benutzer oder dem physikalischen PC verknüpft sein sollen.

  5. Sie können die Registerkarte für Benutzer ausblenden, wenn Sie möchten, dass ausschließlich Konsolebenutzer die Informationen aktualisieren können. Heben Sie die Markierung des Feldes Beim Client anzeigen auf, um diese Registerkarte beim Start des Dialogfelds "Benutzerdetails" auf den Client PCs auszuschließen.

  6. Um Objekte zur Registerkarte hinzuzufügen, wählen Sie einen Control und ziehen ihn mit der Drag&&Drop-Funktion an den gewünschten Ort auf der Seite.

  7. Geben Sie die Eigenschaften und assoziierten Werte für jeden Control ein.

  8. Klicken Sie auf "OK", wenn die Seite vollständig ist.


Nicht-Standard-Hardware hinzufügen

DNA liefert die Tools zur Protokollierung der Details für Objekte, die sich dynamisch nicht finden lassen. Es kann sich dabei um einen entfernten oder alleinstehenden PC handeln, oder Sie haben u. U. zusätzliche Hardwaregeräte, die aufgezeichnet werden müssen, damit das Inventarregister stimmt.

Um die Identifizierung zu erleichtern, können Sie in der Konsolestrukturansicht spezifische Abteilungen für die Speicherung dieser "nicht gescannten" Objekte erstellen, oder Sie können ein Zusatzgerät mit einem bestimmten Client verknüpfen.

  1. Während die Registerkarte "Hardware" ausgewählt ist, wählen Sie {Hardware}{Nicht-Standard-Hardware hinzufügen} in der Menüleiste.

  2. Wählen Sie eine der beiden verfügbaren Optionen und klicken Sie auf "Weiter".

Nicht Windows basierten PC erstellen

Wählen Sie diese Option, um ein nicht gescanntes Hardwareobjekt/Zusatzgerät mit einer Abteilung zu verknüpfen.

Alleinstehenden/entfernten PC importieren

Wählen Sie diese Option, um Inventardaten für einen entfernten oder alleinstehenden PC hinzuzufügen.


Konsolefenster - Registerkarte "Zusammenfassung"

In der Registerkarte "Zusammenfassung" sehen Sie eine statistische Übersicht über einige der wichtigsten Features von DNA. Von hier aus können Sie schnell das tatsächliche Informationsfenster für die betreffende Komponente einblenden, indem Sie auf Weitere Details klicken.

Wie bei allen DNA-Komponenten lassen sich die Daten auf den Ebenen Unternehmen, Abteilung, dynamische Gruppe oder Client betrachten. Wählen Sie hierzu einfach in der Strukturansicht die gewünschte Option.


History-Fenster

Die Option "History" ermöglicht das Tracking von Änderungen an der Hardware und Software eines Clients.

Bei jedem Sammeln von Inventardaten vergleicht DNA die aktuellen Details mit bereits auf dem Server vorhandenen Informationen und wenn es Unterschiede gibt, werden diese in der History aufgezeichnet.

  1. Wählen Sie die Registerkarte "History" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - History}. Das Fenster "History-Zusammenfassung" wird eingeblendet.

  2. Sie können die History auf folgenden Ebenen betrachten: Unternehmen, Abteilung, dynamische Gruppe oder Client. Wählen Sie die gewünschte Ebene in der hierarchischen Strukturansicht.

  3. Zum Umschalten zwischen Hardware- und Softwareänderungen klicken Sie auf den entsprechenden Link im Informationsfenster.

    Oder

    Wählen Sie {History}{Hardware oder Software} in der Menüleiste. Oder klicken Sie auf die entsprechende History-Schaltfläche in der Symbolleiste, wenn eine solche aktiviert ist.

    Klicken Sie auf eine der drei Optionen unten im linken Fensterbereich, um die Anzeige anzupassen:

Betrachten

Ermöglicht das Betrachten von Daten während einer angegebenen Zeitspanne. Jedes Mal, wenn Sie die Betrachtungskriterien verändert haben, klicken Sie auf [image], um die Anzeige zu aktualisieren.

Abfragen

Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Klicken Sie auf [image] , um eine neue Abfrage zu erstellen und auf [image] , um ein vorhandenes Objekt in der Liste zu bearbeiten.

Berichte

Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.


Hardwareinventarisierung

Der DNA Server empfängt bei der Verbindungsherstellung Hardwareinformationen von jedem Client. Die Daten lassen sich im Informationsfenster in verschiedenen Formaten betrachten.

  1. Klicken Sie auf die Registerkarte "Hardware" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Hardware}. Das Fenster "Hardwareinventarisierung" wird eingeblendet.

Wählen Sie in der hierarchischen Strukturansicht die Ebene, auf der Sie die Hardwareinformationen betrachten möchten: Unternehmen, Abteilung, dynamische Gruppe oder individueller Client. Es sind nun verschiedene Anzeigeoptionen verfügbar. Unten im linken Fensterbereich sehen Sie drei Registerkarten.

Betrachten

Im Informationsfenster ist ein Breakdown für jedes gewählte Objekt in Grafik- und Listenformat angezeigt. Klicken Sie auf das entsprechende Symbol, um die Grafik in einem anderen Format zu betrachten. Es ist auch eine Druckoption verfügbar.

Aufgelistete Beschreibungen lassen sich erweitern, so dass Sie ein individuelles Clientbreakdown für jedes Objekt erhalten.

Abfragen

Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Klicken Sie auf [image] , um eine neue Abfrage zu erstellen und auf [image] , um ein vorhandenes Objekt in der Liste zu bearbeiten.

Berichte

Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.

Die Häufigkeit, mit der der Server Daten sammelt, lässt sich mit der Option "DNA-Einstellungen" ändern.

Wenn Sie wissen, dass das Inventar für einen bestimmten Client oder eine Abteilung nicht mehr aktuell ist, können Sie die Schnellaktualisierungsfunktion verwenden. Klicken Sie mit der rechten Maustaste auf das gewünschte Objekt in der Strukturansicht und wählen Sie "Aktualisieren" oder wählen Sie in der Menüleiste die Optionen {Hardware}{Aktualisieren}.


Inventardaten für entfernte Benutzer oder nicht gescannte Geräte sammeln

Damit genaue Informationen über das Inventar verfügbar sind, müssen unbedingt alle Daten zu Benutzer, Hardware und Software aufgezeichnet werden. Der DNA Server ruft zwar automatisch Informationen von den Rechnern ab, auf denen ein Client installiert ist, aber es treten wahrscheinlich trotzdem Instanzen auf, in denen gewisse Objekte nicht auffindbar sind. Sie haben vielleicht Benutzer in entfernten Büros, die nicht an das Netzwerk angeschlossen sind, und Sie werden wahrscheinlich Zusatzgeräte wie Router, Webcams, usw. kaufen.

Um sicherzustellen, dass auch diese Informationen bekannt sind, liefert DNA die Tools zum Sammeln von Daten für entfernte/alleinstehende PCs und dem Protokollieren von Details für Zusatzgeräte.


Entfernten PC hinzufügen

Mit diesem Programm lässt sich das Hardware/Software-Inventar für "alleinstehende" PCs, die nicht dynamisch von DNA gefunden werden können, importieren.

Die im DNA-Programmordner installierte Datei DNAInv.exe wird auf dem entfernten PC ausgeführt. Dieser erstellt seinerseits eine BIN-Datei, welche die Inventardaten enthält. Der Bediener importiert die BIN-Datei in DNA und der Benutzer wird zusammen mit den verknüpften Hardware- und Software-Inventardaten zur Konsole hinzugefügt.

Erhalten der Inventardaten

  1. Kopieren Sie die Datei DNAInv.exe aus \\Programme\netsupport_dna\dna\console\ und senden/emailen/transportieren Sie sie an den/die gewünschte(n) Benutzer.

  2. Führen Sie die Datei auf den gewünschten Rechnern aus. Die Inventardaten werden in einer neuen Datei aufgezeichnet: 'machine_name.BIN'. Diese ist an den Bediener/Administrator zurückzusenden.

  3. Nach Empfang der BIN-Datei muss sie der Bediener an einen passenden Speicherort kopieren, so dass sie zum Import der aufgezeichneten Inventardaten bereit ist.

Importieren der Daten

  1. Laden Sie die DNA-Konsole und, während die Registerkarte "Hardware" ausgewählt ist, wählen Sie {Hardware}{Nicht-Standard-Hardware hinzufügen} in der Menüleiste.

  2. Das Dialogfeld "PC-Typ auswählen" wird eingeblendet. Wählen Sie Alleinstehenden/entfernten PC importieren.

  3. Das Dialogfeld "Entfernten PC hinzufügen" wird eingeblendet.

  4. Geben Sie den Speicherort der BIN-Datei an und klicken Sie auf "Weiter".

  5. Das Inventar wird importiert und die Benutzerdetails werden zur Strukturansicht hinzugefügt.

  6. Klicken Sie auf Fertig stellen, um den Prozess zu beenden oder klicken Sie auf Anderen PC erstellen, um ein anderes Inventar zu importieren. Sie können ggf. auch zusätzliche Hardwareobjekte zu dem neuen Datensatz hinzufügen.


Hardware-Zusatzgeräte hinzufügen

Sämtliche zusätzliche/nicht gescannte Hardware muss aufgezeichnet werden, um ein korrektes Inventarprotokoll zu führen. DNA ermöglicht die manuelle Verknüpfung der Details dieser Komponenten mit ihren jeweiligen "Eigentümern".

  1. Sie können beim Erstellen des "nicht gescannten" Hardware-Datensatzes ein Zusatzgerät hinzufügen.

    Oder

    Um das Gerät mit einem vorhandenen Objekt in der Strukturansicht zu verknüpfen, klicken Sie mit der rechten Maustaste auf einen Client oder ein "nicht gescanntes" Objekt in der Struktur und wählen Zusätzliche Hardware.

    Oder

    Wählen Sie {Hardware}{Zusätzliche Hardware} in der Menüleiste.

  2. Wählen Sie in der Strukturansicht den PC, mit dem die Hardware verknüpft werden soll.

  3. Geben Sie die Details für das Zusatzgerät ein. Wählen Sie entweder eine vorhandene Komponente in der Dropdownliste oder erstellen Sie durch Klicken auf Geräte ein neues Objekt.

  4. Beim Erstellen des Geräts in Schritt 3 können Sie angeben, dass u. U. mehrere Instanzen des Objekts auftreten. Zum Verknüpfen der einzelnen Instanzen klicken Sie auf Hinzufügen. Klicken Sie auf Entfernen, um ein zur Zeit angefügtes Objekt zu löschen.

  5. Geben Sie die Gerätewerte, zum Beispiel die spezifische Marke/das Modell des Geräts, die im Hardwareinventar aufgeführt werden sollen, ein.

  6. Klicken Sie auf Speichern.

  7. Sie können durch Wiederholen dieses Prozesses weitere Geräte hinzufügen oder wenn Sie fertig sind auf Schließen klicken.


Softwareinventarisierung

Der DNA Server empfängt bei der Verbindungsherstellung Softwareinformationen von jedem Client. Standardmäßig sucht DNA nach exe-Dateien, aber die Suche lässt sich auf zusätzliche Ressourcen erweitern, die Sie getrennt von den Hauptanwendungen betrachten können. Die Daten lassen sich im Informationsfenster in verschiedenen Formaten betrachten. Sie können Anwendungsgruppen einrichten, um Lizenzstufen festzuhalten und Situationen hervorzuheben, wenn mehr als eine Version derselben Anwendung installiert ist.

  1. Klicken Sie auf die Registerkarte "Software" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Software}. Das Fenster "Softwareinventarisierung" wird eingeblendet.

Wählen Sie in der hierarchischen Strukturansicht die Ebene, auf der Sie die angezeigten Daten betrachten möchten: Unternehmen, Abteilung, dynamische Gruppe oder individueller Client. Es sind nun verschiedene Anzeigeoptionen verfügbar. Unten im linken Fensterbereich sehen Sie drei Registerkarten.

Betrachten

Im Informationsfenster ist ein Breakdown für jedes gewählte Objekt in Grafik- und Listenformat angezeigt. Klicken Sie auf das entsprechende Symbol, um die Grafik in einem anderen Format zu betrachten. Es ist auch eine Druckoption verfügbar.

Aufgelistete Beschreibungen lassen sich erweitern, so dass Sie ein individuelles Clientbreakdown für jedes Objekt erhalten.

Standardmäßig sucht DNA die Client PCs nach ausführbaren Dateien ab, aber Sie können ggf. auch zusätzliche Dateitypen hinzufügen. Mit der Option "DNA Softwareinventarisierung - Einstellungen" lässt sich angeben, welche anderen Dateien in die Suche aufzunehmen sind. Die Ergebnisse erscheinen getrennt zum Hauptinventar. Klicken Sie auf den Link Softwareressourcen im Informationsfenster.

Abfragen

Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Klicken Sie auf [image], um eine neue Abfrage zu erstellen und auf [image], um ein vorhandenes Objekt in der Liste zu bearbeiten.

Berichte

Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.

Die Häufigkeit, mit der der Server Daten sammelt, lässt sich mit der Option "DNA-Einstellungen" ändern.

Wenn Sie wissen, dass das Inventar für einen bestimmten Client oder eine Abteilung nicht mehr aktuell ist, können Sie die Schnellaktualisierungsfunktion verwenden. Klicken Sie mit der rechten Maustaste auf das gewünschte Objekt in der Strukturansicht und wählen Sie "Aktualisieren" oder wählen Sie in der Menüleiste die Optionen {Software}{Aktualisieren}.

Anwendungsgruppenkategorien sind nützlich, um die Anzahl der im Informationsfenster aufgeführten Objekte zu beschränken. Die erstellten Kategorien lassen sich im linken Bereich des Informationsfensters auswählen und es werden nur Anwendungen, die zu der betreffenden Gruppe gehören, aufgeführt.


Anwendungsgruppen

Bei der Softwareinventarisierung werden alle gescannten Anwendungen zwar standardmäßig eingeschlossen, aber Sie können den Inhalt anpassen, um den Umgang mit der Liste zu vereinfachen. Mit der Option "Anwendungsgruppen" können Sie bestimmen, welche Objekte in das Inventar aufgenommen werden und es lassen sich mehrere Versionen derselben Software in den gleichen Record zusammenführen. Lizenzstufen lassen sich ebenfalls verwalten.

Ferner können Sie über die Option "Anwendungsmetering" auf die Gruppen zugreifen.

  1. Während die Registerkarte "Software" ausgewählt ist, wählen Sie {Software}{Anwendungen} in der Menüleiste. Das Dialogfeld "Anwendungsgruppen" wird eingeblendet. Hier sind die auf allen Client PCs gefundenen Anwendungen aufgeführt, sowie die Anzahl der Lizenzen, wenn diese aufgezeichnet wurde. Das Kontrollkästchen neben jeder Anwendung zeigt an, ob sie zum Inventar gehört oder nicht.

Um die Eigenschaften und Lizenzdetails einer Anwendung zu ändern, wählen Sie ein Objekt in der Liste und klicken auf "Bearbeiten".

Mehrere Anwendungen lassen sich zu einer neuen Anwendungsgruppe zusammenführen. Wählen Sie die gewünschten Objekte (durch Umschalt-Klick oder Strg-Klick) und klicken Sie auf "Zusammenführen".


Anwendungsgruppe bearbeiten

In diesem Dialogfeld können Sie die Eigenschaften und Lizenzinformationen einer Anwendungsgruppe bearbeiten.

In Softwareliste zeigen

Ermöglicht die Beschränkung der Anzahl Objekte, die in der Softwareinventarisierung aufgeführt sind. Wenn diese Option nicht markiert ist, wird die Anwendung aus der Liste der angezeigten Objekte entfernt.

In Anwendungsmetering zeigen

Wenn diese Option nicht markiert ist, wird die Anwendung aus dem Informationsfenster für das Anwendungsmetering entfernt.

Lizenzen

Hier können Sie festhalten, wie viele Lizenzen mit der Anwendung verknüpft sind. Klicken Sie auf [image] , um zusätzliche Lizenzinformationen hinzuzufügen.

Beschreibung

Zeigt den Namen der gewählten Anwendung an. Sie können die aufgeführte Beschreibung für beliebige Objekte ggf. ändern. Scrollen Sie mit [image] rückwärts oder vorwärts durch die einzelnen Objekte, um die Anwendungseigenschaften einzublenden. Geben Sie ggf. eine neue Beschreibung ein.

Anwendungsgruppenkategorie

Hier können Sie Kategorien erstellen, in die sich "ähnliche" Anwendungen gruppieren lassen. In den Fenstern "Softwareinventarisierung" und "Anwendungsmetering" lassen sich Objekte nach Gruppe anzeigen statt "alle" Objekte aufzuführen. Die Suche nach spezifischen Records wird dadurch erleichtert. Klicken Sie auf [image] , um eine neue Kategorie zu erstellen.

Zusammenführen rückgängig

Zusammengeführte Anwendungen lassen sich ggf. wieder trennen.


Anwendungsgruppen zusammenführen

In diesem Dialogfeld können Sie mehrere Anwendungen in eine einzige Gruppe zusammenführen. Ideal für die Suche verschiedener Versionen derselben Software.

Zusammenführen in 'xxxxxxxxxxx'

Der neuen Anwendungsgruppe kann der Name eines der aufgeführten Objekte zugewiesen werden. Klicken Sie auf den gewünschten Namen, um ihn auszuwählen.

Neue Anwendungsgruppe

Oder geben Sie einen neuen Namen für die neue Gruppe ein.

In Softwareliste zeigen

Wenn diese Option nicht markiert ist, erscheint die neue Anwendungsgruppe nicht in der Softwareinventarisierung.

In Anwendungsmetering zeigen

Wenn diese Option nicht markiert ist, wird die Anwendungsgruppe aus dem Informationsfenster für das Anwendungsmetering entfernt.

Klicken Sie auf Zusammenführen, um die neue Gruppe zu erstellen. Das Zusammenführen der Anwendungen kann später ggf. wieder rückgängig gemacht werden.


Internet-Metering

Das Internet-Metering-Tool sammelt Details der Websites, die Clients besuchen. Es protokolliert die Start- und Endzeit jedes Besuches sowie die aktive Gesamtzeit. Sie können ggf. zur Einhaltung der internen Firmenpolitik den Zugriff auf bestimmte Sites genehmigen oder einschränken und zeitliche Beschränkungen auf die Verwendung von Sites anwenden.

  1. Klicken Sie auf die Registerkarte "Internet-Metering" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Internet-Metering}. Das Fenster "Internet-Metering" wird eingeblendet.

Wählen Sie in der hierarchischen Strukturansicht die Ebene, auf der Sie die Meteringdaten betrachten möchten: Unternehmen, Abteilung, dynamische Gruppe oder individueller Client. Es sind nun verschiedene Anzeigeoptionen verfügbar. Unten im linken Fensterbereich sehen Sie drei Registerkarten.

Betrachten

Im Informationsfenster ist ein Breakdown für jedes gewählte Objekt in Grafik- und Listenformat angezeigt. Klicken Sie auf das entsprechende Symbol, um die Grafik in einem anderen Format zu betrachten. Es ist auch eine Druckoption verfügbar.

Aufgelistete Beschreibungen lassen sich erweitern, so dass Sie ein individuelles Clientbreakdown für jedes Objekt erhalten.

Sie können die Internet-Nutzung für eine vorgegebene Zeitspanne, den aktuellen Tag oder die letzten 7 Tage betrachten. Sites, die kürzer als eine angegebene Zeitspanne aktiv waren, lassen sich ggf. ignorieren.

Jedes Mal, wenn Sie die Betrachtungskriterien verändert haben, klicken Sie auf [image], um die Anzeige zu aktualisieren.

Abfragen

Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Klicken Sie auf [image], um eine neue Abfrage zu erstellen und auf [image], um ein vorhandenes Objekt in der Liste zu bearbeiten.

Berichte

Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.

Die Häufigkeit, mit der der Server Daten sammelt, lässt sich mit der Option "DNA-Einstellungen" ändern. Dies ermöglicht Ihnen gleichzeitig die Aktivierung von etwaigen Einschränkungen der Internet-Nutzung.

Mit einer Schnellaktualisierungsfunktion können Sie Daten außerhalb der angegebenen Häufigkeit aktualisieren. Dies kann nützlich sein, wenn Sie bestimmte Clients oder Abteilungen anpeilen möchten. Klicken Sie mit der rechten Maustaste auf das gewünschte Objekt in der Strukturansicht und wählen Sie "Aktualisieren" oder wählen Sie in der Menüleiste die Optionen {Internet-Metering}{Aktualisieren}.


Internet-Einschränkungen

Sie können die von Clients besuchten Sites kontrollieren, indem Sie genehmigte und eingeschränkte Listen erstellen. Sie bestimmen, welche URL Benutzer besuchen dürfen oder nicht, und dann aktivieren Sie die gewünschte Liste über die Internet-Metering-Einstellungen.

Hinweis: Zur Verwendung der Internet-Blockierungsfunktion müssen Sie zunächst sicherstellen, dass DNAs Winsock Layered Service Provider (LSP) auf den Clientcomputern aktiviert ist. Dies erfordert das Deploy eines DNA Clients mit aktiviertem LSP an die gewünschten PCs.

  1. Klicken Sie auf die Registerkarte "Internet-Metering" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Internet-Metering}.

  2. Wählen Sie {Internet-Metering}{Meteringeinstellungen} in der Menüleiste. Das Dialogfeld "Internet-Metering" wird eingeblendet. Bereits besuchte URL werden automatisch aufgeführt und Sie können auch manuell Sites zu der Liste hinzufügen.

  3. Wählen Sie in der Liste mit verfügbaren Sites eine vorhandene URL oder klicken Sie auf [image], um eine neue Site hinzuzufügen. Auf jedes Objekt kann ein "Filter" angewendet werden, um sicherzustellen, dass sämtliche Instanzen der URL abgedeckt sind, *.co.uk, *.net, *.com, usw. Klicken Sie auf [image], um die URL/den Filter eines aufgelisteten Objekts zu bearbeiten.

  4. Übertragen Sie die gewählte URL in die Liste mit genehmigten oder eingeschränkten Sites, indem Sie auf Genehmigen oder Beschränken klicken oder die URL mit der Drag&&Drop-Funktion in die gewünschte Kategorie ziehen.

  5. Klicken Sie auf OK.

Die Listen lassen sich nun wunschgemäß und zu einem beliebigen Zeitpunkt aktivieren. Wählen Sie in der hierarchischen Strukturansicht die Ebene, auf der die Einschränkungen gelten sollen: Unternehmen oder Abteilung. Wählen Sie in der Menüleiste die Optionen {Bearbeiten}{Einstellungen} oder klicken Sie in der Symbolleiste auf das Symbol "Komponenteneinstellungen". Wählen Sie die Option Internet-Metering-Einstellungen und ändern Sie die Einstellungen wunschgemäß.


Anwendungsmetering

Mit dem Anwendungsmeteringtool können Sie die Nutzung von Anwendungen in Ihrer Organisation überwachen. Die Daten lassen sich im Informationsfenster in verschiedenen Formaten betrachten.

DNA berichtet über alle auf einem PC genutzten Anwendungen und gibt an, wie lange die Anwendung genutzt wurde. Sie können sogar durch die Erstellung von genehmigten/eingeschränkten Listen sicherstellen, dass die Anwendungsnutzung Ihrer Firmenpolitik entspricht und es lassen sich mögliche Lizenzprobleme identifizieren.

  1. Klicken Sie auf die Registerkarte "Anwendungsmetering" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Anwendungsmetering}. Das Fenster "Anwendungsmetering" wird eingeblendet.

Wählen Sie in der hierarchischen Strukturansicht die Ebene, auf der Sie die Meteringdaten betrachten möchten: Unternehmen, Abteilung, dynamische Gruppe oder individueller Client. Es sind nun verschiedene Anzeigeoptionen verfügbar. Unten im linken Fensterbereich sehen Sie drei Registerkarten.

Betrachten

Im Informationsfenster ist ein Breakdown für jedes gewählte Objekt in Grafik- und Listenformat angezeigt. Klicken Sie auf das entsprechende Symbol, um die Grafik in einem anderen Format zu betrachten. Es ist auch eine Druckoption verfügbar.

Aufgelistete Beschreibungen lassen sich erweitern, so dass Sie ein individuelles Clientbreakdown für jedes Objekt erhalten.

Sie können die Anwendungsnutzung für eine vorgegebene Zeitspanne, den aktuellen Tag oder die letzten 7 Tage betrachten. Anwendungen, die kürzer als eine angegebene Zeitspanne geöffnet waren, lassen sich ggf. ignorieren.

Eine hilfreiche Methode zur Anpeilung einer spezifischen Anwendungsnutzung und Beschränkung der angezeigten Datenmenge ist die Gruppierung "ähnlicher" Anwendungen. Wenn Sie z. B. herausfinden möchten, wie viel Zeit mit dem Spielen von Solitaire verbracht wird, können Sie eine Gruppe erstellen, die Spiele enthält. Weitere Angaben hierzu finden Sie unter "Anwendungsgruppen".

Jedes Mal, wenn Sie die Betrachtungskriterien verändert haben, klicken Sie auf [image], um die Anzeige zu aktualisieren.

Abfragen

Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Klicken Sie auf [image], um eine neue Abfrage zu erstellen und auf [image], um ein vorhandenes Objekt in der Liste zu bearbeiten.

Berichte

Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.

Die Häufigkeit, mit der der Server Daten sammelt, lässt sich mit der Option "DNA-Einstellungen" ändern.

Mit einer Schnellaktualisierungsfunktion können Sie Daten außerhalb der angegebenen Häufigkeit aktualisieren. Dies kann nützlich sein, wenn Sie bestimmte Clients oder Abteilungen anpeilen möchten. Klicken Sie mit der rechten Maustaste auf das gewünschte Objekt in der Strukturansicht und wählen Sie "Aktualisieren" oder wählen Sie in der Menüleiste die Optionen {Anwendungsmetering}{Aktualisieren}.


Anwendungseinschränkungen

Um sicherzustellen, dass die Anwendungsnutzung Ihrer Firmenpolitik entspricht, können Sie Listen mit genehmigten oder beschränkten Anwendungen erstellen und Zeitrahmen für die Gültigkeit dieser Einschränkungen festlegen.

  1. Klicken Sie auf die Registerkarte "Anwendungsmetering" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Anwendungsmetering}.

  2. Wählen Sie {Anwendungsmetering}{Anwendungseinschränkungen} in der Menüleiste.

  3. Das Dialogfeld "Anwendungseinschränkungen" wird eingeblendet.

Verwaltete Anwendungen zeigen

Wenn diese Option markiert ist, können Sie auf einen Blick sehen, welche Anwendungen bereits eingeschränkt sind und auf welche Benutzer sich dies bezieht.

Wenn diese Option nicht markiert ist, wird eine vollständige Liste mit gescannten Anwendungen eingeblendet, in der Sie auswählen können, welche Anwendungen Sie einschränken möchten.

Übernehmen von Einschränkungen

  1. Markieren Sie die gewünschte Anwendung in der Liste. Im Fenster "Genehmigt für" ist die Clientstrukturansicht eingeblendet.

  2. Um die Nutzung der Anwendung durch bestimmte Clients einzuschränken, markieren Sie diese in der Strukturansicht und klicken auf [image]. Die Details werden im Fenster Eingeschränkt für eingeblendet.

  3. Sie können die Einschränkungen nur für bestimmte Tageszeiten gelten lassen.

  4. Klicken Sie auf "OK", um die Details zu speichern. Im Fenster "Anwendungsliste" sehen Sie, für wie viele Clients die Einschränkung gilt.


Softwareverteilung

DNA bietet eine mehrfache Lieferungsoption für die Softwareverteilung, was zeitgerechte und kostengünstige Anwendungsdeployments im ganzen Unternehmen ermöglicht. Ein Bediener definiert ein Softwarepaket, das eine Sammlung der Dateien oder Ordner, die verteilt werden sollen, enthält. Nachdem das Paket erstellt ist, kann es automatisch an Ziel-PCs verteilt oder zentral "veröffentlicht/angeboten" werden, damit Benutzer auf Verlangen darauf zugreifen und es installieren können.

Es lassen sich auch Aktionsparameter in das Paket aufnehmen, was es Ihnen zum Beispiel ermöglicht, alle während der Anwendungsinstallation erforderlichen Eingabeaufforderungen an den Benutzer einzubauen, so dass sich das Paket dann ohne Eingriffe an das System eines Benutzers verteilen lässt.

Beim Planen einer Deploy-Funktion können Sie die Hardware- und Softwareinventarisierungsfeatures von DNA verwenden, um den aktuellen Inventarstatus in Ihrer Organisation zu beurteilen und so die Kompatibilität zu gewährleisten. Ähnlich konfigurierte Systeme lassen sich zusammen gruppieren, um eine möglichst effiziente Einführung zu gewährleisten.

DNA berücksichtigt auch die Auswirkungen, die ein Deploy großer Pakete im ganzen Netzwerk haben kann. Netzwerkoverheads wachsen natürlich, während Pakete vom DNA Server an mehrere Clientcomputer verteilt werden. Damit die Überlastung weniger akut wird, können Sie in der Nähe der Clientcomputer ein "Verteilungswarehouse" erstellen. Das Paket wird an das Warehouse gesendet und genannte Clients werden dann von diesem lokalen "Server" aus bedient.

  1. Klicken Sie auf die Registerkarte "Verteilung" oder wählen Sie in der Menüleiste die Optionen {Betrachten}{Komponente - Verteilung}.

Wählen Sie in der hierarchischen Strukturansicht die Ebene, auf der Sie die Verteilungsdaten betrachten möchten: Unternehmen, Abteilung, dynamische Gruppe oder individueller Client. Es sind nun verschiedene Anzeigeoptionen verfügbar. Unten im linken Fensterbereich sehen Sie drei Registerkarten.

Betrachten

Im Hauptinformationsfenster ist ein Breakdown der verteilten Pakete für jedes gewählte Objekt in Grafik- und Listenformat angezeigt. Klicken Sie auf das entsprechende Symbol, um die Grafik in einem anderen Format zu betrachten. Es ist auch eine Druckoption verfügbar.

Die Drilldownlisten lassen sich erweitern, so dass Sie ein individuelles Clientbreakdown für jedes Objekt erhalten.

Je nachdem, welche Ebene in der Struktur hervorgehoben ist, ist im Betrachtungsfenster markiert, welche Verteilungswarehouses in Betrieb sind und welche Clients vom betreffenden Warehouse bedient werden. Das Softwareverteilungs-Warehouse dient als zentrales Repository für die Speicherung von Paketen zur Verteilung. Im Idealfall befindet sich das Warehouse auf einem Rechner in der Nähe der Zielcomputer, was beim Verteilen der Pakete die Overheads verringert.

Abfragen

Mit dem Abfragetool von DNA können Sie Datenbankeinträge abrufen, die bestimmte Kriterien erfüllen. Abfragen zu der Komponente, die gerade betrachtet wird, sind aufgelistet, was ein schnelles Abrufen der Ergebnisse ermöglicht.

Klicken Sie auf [image] , um eine neue Abfrage zu erstellen und auf [image] , um ein vorhandenes Objekt in der Liste zu bearbeiten.

Berichte

Jeder Komponente ist eine Reihe von vordefinierten Managementberichten, die vom Crystal Reports-Modul gespeist werden, beigefügt. Wählen Sie den gewünschten Bericht. Die Ergebnisse erscheinen im Informationsfenster. Sie lassen sich ggf. exportieren.


Software-Verteilungspakete erstellen

  1. Während die Registerkarte "Verteilung" ausgewählt ist, wählen Sie {Verteilung}{Paketverwaltung}.

    Oder

    Wählen Sie {Tools}{Paketverwaltung} in der Menüleiste.

    Oder

    Klicken Sie auf "Pakete" in der Symbolleiste.

  2. Das Dialogfeld "Paketverwaltung" wird eingeblendet. Hier sind Angaben zu vorhandenen Paketen aufgeführt. Alle, die markiert sind, werden auf Client PCs angeboten.

  3. Klicken Sie auf "Neu", um zusätzliche Pakete zur Verteilung zu erstellen.

    Oder

    Klicken Sie auf "Löschen", wenn ein Paket in der Liste nicht mehr benötigt wird.

    Oder

    Klicken Sie auf "Kopieren", um eine Kopie eines vorhandenen Pakets anzufertigen. Dies kann nützlich sein, wenn Sie dasselbe Paket mit zusätzlichen Parametern verteilen möchten. Die geänderte Version wird zur Liste hinzugefügt.


Verteilen eines Pakets

Nachdem Sie das gewünschte Paket erstellt haben, kann dieses an gewählte Clients verteilt werden.

  1. Markieren Sie in der Strukturansicht den Client, die Abteilung, die dynamische Gruppe oder das Unternehmen, an die Sie das Paket verteilen möchten.

  2. Klicken Sie mit der rechten Maustaste and wählen Sie "Paket verteilen".

    Oder

    Während die Registerkarte "Verteilung" ausgewählt ist, wählen Sie {Verteilung}{Paket verteilen} in der Menüleiste.

    Oder

    Klicken Sie auf "Verteilen" in der Symbolleiste.

  3. Alle vorher erstellten Pakete sind aufgeführt. Markieren Sie die gewünschte Datei. Wenn das gewünschte Paket nicht verfügbar ist, können Sie es von hier aus erstellen. Klicken Sie auf "Neu".

  4. Wenn Sie an ein Unternehmen oder eine Abteilung verteilen, stellen Sie sicher, dass das Feld Unterabteilungen einschließen markiert ist, wenn Sie alle Abteilungen/Clients im betreffenden Bereich einschließen möchten.

  5. Bevor Sie fortfahren, können Sie den Status der PCs, an die Sie verteilen werden, überprüfen. Dies zeigt an, ob die PCs verfügbar (grün), nicht verfügbar (rot) oder abgemeldet (gelb) sind.

  6. Klicken Sie auf "OK", um das Paket zu verteilen. Die Ergebnisse werden im Verteilungsfenster eingeblendet.


Anbieten eines Pakets

Das Anbieten oder Veröffentlichen eines Pakets gibt Clients die Möglichkeit, ein Paket zu installieren, wann es ihnen passt. Pakete werden auf die übliche Weise erstellt, aber statt sofort verteilt zu werden, bleiben die Setupdateien beim Server und lassen sich nach Bedarf von genannten Clients abrufen.

  1. Markieren Sie in der Strukturansicht den Client, die Abteilung, die dynamische Gruppe oder das Unternehmen, denen Sie das Paket anbieten möchten.

  2. Klicken Sie mit der rechten Maustaste and wählen Sie "Paket anbieten".
    Oder
    Während die Registerkarte "Verteilung" ausgewählt ist, wählen Sie {Verteilung}{Paket anbieten} in der Menüleiste. Oder
    Klicken Sie auf "Anbieten" in der Symbolleiste.

  3. Das Dialogfeld "Paket anbieten" wird eingeblendet. Alle mit aktivierter Option "Beim Client sichtbar" erstellten Pakete sind aufgeführt.

  4. Wählen Sie das gewünschte Paket und klicken Sie auf "Anbieten", um es in das Feld "Angeboten" zu übertragen.

  5. Wählen Sie "Unterabteilungen einschließen", wenn Sie möchten, dass alle nachfolgenden Abteilungen/Clients in die Verteilung eingeschlossen werden.

  6. Klicken Sie auf "OK".


Anfordern eines Pakets

Angebotene Pakete lassen sich mit dem Paketanforderungstool durch Clients vom Server abrufen.

  1. Klicken Sie auf dem Clientcomputer mit der rechten Maustaste auf das DNA-Symbol in der Taskleiste und wählen Sie "Paket anfordern".

  2. Das Dialogfeld Paketliste wird eingeblendet, in dem alle für diesen Client verfügbaren Pakete aufgeführt sind.

  3. Markieren Sie das gewünschte Paket und klicken Sie auf Abrufen. Die Anwendungs-Setupdateien werden beim Client ausgeführt. Der Status des Pakets ändert sich zur Anzeige, dass es an den Client geliefert wurde.

Hinweis: Konsolebediener können den Zugriff eines Clients auf die Paketanforerungsfunktion sperren, indem sie die Software-Verteilungseinstellungen bearbeiten. Sie können auch gemäß obigem Muster "nicht" angebotene Pakete in die Paketliste aufnehmen, während Clients nur zur Installation von angebotenen Objekten befähigt sind.


Importieren eines Pakets

Mit der Importoption lässt sich ein gespeichertes Verteilungspaket vom Server abrufen, um den Paketinhalt zu bearbeiten.

  1. Während die Registerkarte "Verteilung" ausgewählt ist, wählen Sie {Verteilung}{Paketverwaltung} oder {Tools}{Paketverwaltung} in der Menüleiste. Das Dialogfeld Paketverwaltung wird eingeblendet.

  2. Wählen Sie Neu. Das Dialogfeld Neues Paket erstellen wird eingeblendet.

  3. Wählen Sie Importieren. Bewegen Sie sich zum Paketordner, \\programme\netsupport dna\dna\server\pakete, und wählen Sie das gewünschte Paket. Klicken Sie auf Öffnen.

  4. Klicken Sie ggf. auf Aktionen, um zusätzliche Parameter einzuschließen.

  5. Klicken Sie auf "OK".

  6. Geben Sie einen Namen und eine Beschreibung für das Paket ein und klicken Sie auf "OK". Das Paket wird verteilungsbereit erneut an den Server gesendet.


Softwareverteilungs-Warehouse

Berücksichtigen Sie bei der Planung eines umfangreichen Deploys, welche Folgen dies für das Netzwerk haben wird. An mehrere Clients über entfernte Netzwerke verteilte Pakete wirken sich natürlich auf die Ressourcen aus.

Um die Überlastung einzudämmen, können Sie bei DNA einen Client, der sich im Idealfall am gleichen Ort wie die Zielcomputer befindet, zum "Verteilungs-Warehouse" ernennen. Beim Deploy des Pakets muss der Server so nicht an einen Client nach dem anderen verteilen, sondern alles wird beim Warehouse Client installiert, der dann an die übrigen Zielcomputer verteilt.

  1. Während die Registerkarte "Verteilung" ausgewählt ist, wählen Sie {Verteilung}{Warehouse-Verwaltung}.

    Oder

    Klicken Sie auf "Warehouses" in der Symbolleiste.

    Oder

    Wählen Sie in der Konsolestrukturansicht eine Abteilung oder einen Client aus. Das Betrachtungsfenster darunter zeigt die Anwesenheit aller vorhandenen Warehouse PCs an und ermöglicht Ihnen das Erstellen von Warehouses oder das Zuweisen von PCs zu einem Warehouse. Klicken Sie auf den gewünschten Link.

  2. Das Dialogfeld "Warehouse-Verwaltung" wird eingeblendet. Vorhandene Warehouse PCs sind aufgeführt. Markieren Sie ein Objekt, um aktuell von diesem Warehouse bediente Clients und Details der Clients, die zum Hinzufügen verfügbar sind, zu betrachten. Klicken Sie auf Status, um Details für die aktuell im Warehouse befindlichen Pakete anzuzeigen.

  3. Zum Erstellen eines neuen Warehouses klicken Sie auf Hinzufügen. Das Dialogfeld Warehouse auswählen wird eingeblendet. Hier können Sie einen Clientcomputer zum Host für das Warehouse ernennen.

  4. Wählen Sie die Clients, die vom Warehouse bedient werden sollen. Markieren Sie in der Struktur "Verfügbare Clients" den gewünschten Client und klicken Sie auf [image]. Um einen Client aus dem Warehouse zu entfernen, klicken Sie auf [image].

  5. Klicken Sie auf "OK".


DNA Application Packager

DNA Application Packager ergänzt die Softwareverteilungsfunktion und eignet sich ideal für Situationen, in denen die Anwendung, die eingeführt werden soll, keine eigene, "unbeaufsichtigte" Installationsroutine besitzt. (Wenn die Software, die installiert werden soll, unbeaufsichtigte/automatische Routinen unterstützt, wird empfohlen, diese zu verwenden.) Mit dem Packager können Bediener Installationsprogramme von Drittparteien aufzeichnen und wieder abspielen. Alle nötigen Tastenanschläge und Mausbewegungen werden in einem Skript gespeichert, das dann auf den Client-PCs ohne Eingriffe durch den Benutzer wieder abgespielt wird. Die Softwareverteilungsoption von DNA wird verwendet, um das gespeicherte Skript an die gewünschten Client PCs zu senden.

Mit dem Application Packager lassen sich Produktinstaller von "niedriger Komplexität" aufzeichnen und wieder abspielen. Der Packager beruht auf der Anzeige derselben Abfolge von Installerbildschirmen bei Ausführung der Installation auf den Zielcomputern. Wenn im Laufe des Playbacks unerwartete Dialogfelder erscheinen, wird das Installationsverfahren unterbrochen.

Es ist ein Skriptbearbeitungstool verfügbar, mit dem Sie ggf. gewisse Unterschiede beseitigen können.

  1. Wählen Sie zum Laden des Packagers die Optionen {Start}{Programme}{NetSupport DNA}{DNA Application Packager}.

  2. Das Dialogfeld "Willkommen" des Application Packagers wird eingeblendet. Sie werden vom Packager-Assistenten durch den Aufnameprozess geführt.

  3. Klicken Sie auf "Weiter".


DNA Application Packager - Installationsprogramm abrufen

Geben Sie in diesem Dialogfeld an, welches Programm verpackt und in welches Verzeichnis die installierten Setupdateien auf dem Client PC extrahiert werden sollen.

  1. Finden Sie mit der Suchfunktion die gewünschte Programmsetup-Datei.

  2. Geben Sie an, von wo aus das installierte Programm auf den Clientcomputern ausgeführt werden soll. Bei ihrer Verteilung an die Client PCs wird die vom Packager erstellte exe-Datei in c:\programme\netsupport dna\dna\client\pakete gespeichert. Wenn Sie kein anderes festes Verzeichnis, von dem aus Setup in der Zukunft ausgeführt werden soll, angeben, wird immer vom obigen Setupprogramm-Verzeichnis aus auf es zugegriffen.

  3. Klicken Sie auf "Weiter".


DNA Application Packager - Skriptdatei abrufen

Wenn die verpackte Anwendung an Client PCs verteilt wird, sind die für die Installation notwendigen Aktionen in einem vordefinierten Skript festgehalten. Das Skript lässt sich in diesem Stadium durch Ausführen der Installation und Aufzeichnen der Tastatur-/Mausbewegungen erstellen, oder vielleicht haben Sie ein vorhandenes Skript, welches das Verfahren enthält.

Application Packager von DNA enthält ein Skripterstellungsprogramm, mit dem Sie manuell Skriptdateien erstellen und bearbeiten können.

Wenn Sie eine vorher erstellte Skriptdatei verwenden möchten, suchen Sie nach der passenden *.rscrpt-Datei.

Klicken Sie auf "Weiter".


DNA Application Packager - Skript erstellen

Dieses Dialogfeld erscheint, wenn Sie sich für die Erstellung des Skripts durch jetziges Ausführen des Installationsprogramms statt der Verwendung einer vordefinierten *.rscrpt-Datei entschieden haben.

Klicken Sie auf Installation ausführen, um den Installer des gewählten Programms zu starten. Die Installation wird auf dem Rechner des Bedieners in Echtzeit ausgeführt. Während Sie den Prozess durchlaufen, wird jeder Tastendruck und jede Mausbewegung aufgezeichnet und zur Skriptdatei hinzugefügt. Denken Sie daran, dass die Installation nach ihrer Verteilung genau so auf den Client PCs ausgeführt wird. Wenn Sie versehentlich eine falsche Taste drücken oder eine ungewollte Option auswählen, können Sie das Skript vor seiner Verteilung an die Clients bearbeiten.

Wenn die Installation beendet ist, klicken Sie auf Fertig stellen.

Klicken Sie zur Fortsetzung auf Weiter.


DNA Application Packager - Zusätzliche Dateien

Zusätzlich zum gewünschten Installer können Sie mit dem verteilten Paket andere Dateien einschließen. Es sind zum Beispiel u. U. eine Reihe von Dokumenten mit dem Paket verknüpft, deren Zugänglichkeit für Clients nach Installation der Anwendung nützlich sein könnte.

Geben Sie das Quellverzeichnis, ggf. mit Unterverzeichnissen, ein. Identifizieren Sie auf den Clientcomputern ein Zielverzeichnis.

Klicken Sie auf "Weiter".


DNA Application Packager - Erstellungsoptionen

Name für erstelltes Programm

Entscheiden Sie, ob die ausführbare Datei verteilungsbereit gespeichert werden soll.

Optionen

Maus/Tastatur sperren

Während des Installationsverfahrens können Sie die Maus und Tastatur der Clients sperren, um sicherzustellen, dass der automatische Prozess nicht von Benutzern unterbrochen wird.

Abbrechen des Skripts erlauben

Ermöglicht Clients den Unterbruch der Installation durch Drücken von STRG-UNTBR.

Kennwortdetails

Mit diesen Optionen können Sie die verteilte Datei durch ein Kennwort schützen und das Dialogfeld, das auf Clientcomputern erscheint, anpassen.

Klicken Sie auf "Weiter". Das Paket wird nun erstellt.


DNA Application Packager - Script Builder

Im Application Packager von DNA haben Bediener die Möglichkeit, Installationsprogramme von Drittparteien aufzuzeichnen und wieder abzuspielen. Dies eignet sich ideal für Anwendungen, die keine "unbeaufsichtigte" Installationsfunktion bieten. Der Packager führt Bediener durch das Installationsverfahren und zeichnet dabei die erscheinenden Dialogfelder und getätigten Antworten auf. Diese Informationen werden in einem Skript gespeichert.

Wenn Sie mit dem aufgezeichneten Verfahren zufrieden sind, können Sie es an Client PCs verteilen. Es kann jedoch vorkommen, dass Ihrer Ansicht nach eine auf dem Bedienercomputer aufgezeichnete Aktion bei der Ausführung der Installation auf den Client PCs nicht benötigt wird oder dass Sie versehentlich einen falschen Mausklick oder Tastendruck vorgenommen haben.

Mit dem Script Builder können Sie im Application Packager erstellte Skripts bearbeiten oder neue Skripts aufzeichnen.

  1. Zum Laden von Script Builder gehen Sie zu \\programme\netsupport dna\dna\konsole\

  2. Das Dialogfeld "Script Builder" wird eingeblendet.


Neues Skript aufzeichnen

Das Application Packager-Programm liefert zwar einen praktischen Assistenten, der Sie durch das Erstellungsverfahren für das Installerskript führt, aber Sie können die gewünschten Aktionen auch mit dem Script Builder aufzeichnen.

Anwendung

Geben Sie den Speicherort und Namen der gewünschten Anwendungs-Setupdatei ein.

Skriptdatei

Geben Sie einen Speicherort und Namen für die neue Skriptdatei ein.

Klicken Sie auf Aufnahme beginnen, um die angegebene Setupdatei zu starten. Der gewählte Anwendungsinstaller wird gestartet und der Script Builder zeichnet die erscheinenden Dialogfelder sowie die Maus-/Tastaturbewegungen, die der Bediener ausführt, auf. Die Installation findet auf dem Computer des Bedieners in Echtzeit statt, aber denken Sie auch daran, dass dies der Prozess ist, der bei der Verteilung des Skripts auf den Client PCs ausgeführt wird.

Wenn die Installation beendet ist, klicken Sie auf Aufnahme beenden.

Wenn Sie das fertige Skript überprüfen oder infolge einer falschen Aktion Änderungen vornehmen möchten, klicken Sie auf "Bearbeiten".


Skript bearbeiten

Mit dem Script Builder lassen sich gespeicherte Installerskripts wieder abspielen oder bearbeiten.

Playback

Öffnen Sie das gespeicherte Skript (*.rscrpt file).

Klicken Sie auf Abspielen, um die aufgezeichneten Aktionen wieder abzuspielen.

Sie können auch testen, ob sich ein vorhandenes Skript erfolgreich mit einer anderen Setupdatei ausführen lässt, zum Beispiel einer aktualisierten Version der bereits genutzten Anwendung. Klicken Sie auf Abspielen gegen und suchen Sie nach der nächsten Setupdatei.

Beim Playback des Skripts werden u. U. Fehler oder fehlende Aktionen aufgedeckt. Klicken Sie auf Bearbeiten, um Änderungen am Skript vorzunehmen. Der Skripteditor wird eingeblendet.

Im linken Fensterbereich sind Angaben zu den aufgezeichneten Dialogfeldern (Formularen) und durchgeführte Aktionen, wie z. B. Mausklicks, usw., aufgeführt. Wenn Sie eine Zeile des Skripts markieren, erscheinen im rechten Fensterbereich damit verknüpfte Informationen.

Neue Objekte lassen sich ggf. zum Skript hinzufügen:

Hinzufügen

Ermöglicht das Hinzufügen von zusätzlichen Aktionen zu einem Formular.

Formular hinzufügen von

Ermöglicht das Einfügen eines Formulars aus einem anderen Skript. Geben Sie den Namen der Skriptdatei ein und klicken Sie auf "Laden". Das ganze Skript wird eingeblendet. Wählen Sie das individuelle Formular, das Sie hinzufügen möchten.


Bericht- und Analysetools von DNA

DNA liefert zahlreiche Bericht- und Analysetools.

Es sind eine Reihe von vordefinierten Optionen verfügbar, mit denen Sie schnell Informationen über alle Hauptkomponenten von DNA betrachten können: On-Screen-Berichte mit Texten, Balken- und Kreisdiagrammen, bei denen man per Mausklick für jede Hauptsparte erweiterte Details abrufen kann. Darüber hinaus liefert die „Crystal Report Engine“ eine Reihe vorgefertigter Management-Reports. Das sind druckoptimierte Berichte, die man auch als PDF, DOC bzw. XLS-Dokument exportieren und archivieren kann.

Wenn die vordefinierten Optionen Ihre Bedürfnisse nicht vollständig erfüllen, können Sie mit dem DNA-Abfragetool benutzerdefinierte Abfragen erstellen. Abfragen lassen sich an die spezifischen Komponenten anfügen, auf die sie sich beziehen, was ihren Abruf erleichtert. Es können dynamische Gruppen erstellt und in der Strukturansicht aufgeführt werden. Clients, die spezifische Kriterien erfüllen, werden dann dynamisch zur Gruppe hinzugefügt.

Das Tool "Benutzer suchen" ermöglicht eine schnelle Suche nach Clients in der Struktur.

Analyse auf dem Bildschirm

In der unteren linken Ecke des Konsolefensters können Sie bestimmen, welche Art von Bericht Sie möchten: wählen Sie die Registerkarte "Betrachten", "Abfragen" oder "Berichte".

Registerkarte "Betrachten"

Beim Betrachten einer der Komponentenregisterkarten erscheinen die Informationen für ein gewähltes Unternehmen, eine Abteilung oder einen Client in Grafik- und Listenformat.

Die Daten lassen sich durch Wahl des passenden Symbols in einer Reihe von grafischen Formaten darstellen: .

Unter der Grafik sehen Sie dieselben Records in einem Listenformat. Sie können diese Informationen durch Anklicken von + auf eine detailliertere Übersicht erweitern. Hierdurch werden alle individuellen Clientrecords eingeblendet.

Durch Klicken auf [image] können Sie die Records auf dem Bildschirm ausdrucken.

Registerkarte "Abfragen"

Mit dem Abfragetool von DNA lassen sich Ausgaben an Ihre speziellen Bedürfnisse anpassen. Abfragen können mit der Komponente, auf die sie sich beziehen, verknüpft werden, um ein schnelles Abrufen der Ergebnisse zu ermöglichen.

Klicken Sie auf [image], um eine neue Abfrage zu erstellen, oder auf [image], um ein vorhandenes Objekt in der Liste zu bearbeiten.

Registerkarte "Berichte"

DNA liefert eine Reihe von vordefinierten Crystal Reports für jede Komponente. Wählen Sie einfach in der Liste den gewünschten Bericht und die Ergebnisse werden im Informationsfenster angezeigt.

Man kann alle verfügbaren Berichte als PDF, DOC, XLS, XML, HTML, CSV und RTF exportieren. Wählen Sie dazu in der Menüleiste die Optionen {Berichte}{Export}.

Zum Scrollen durch die Berichtseiten lassen sich die Steuerelemente im Dropdownmenü {Berichte} verwenden.


Abfragetool

Das Abfragetool stellt noch eine zusätzliche Erweiterung der in DNA verfügbaren Berichtoptionen dar. Während auf dem Bildschirm angezeigte und vordefinierte Crystal-Berichte zahlreiche vorgefertigte Informationen liefern, ermöglicht das Abfragetool das Anpassen der Ausgabe an Ihre speziellen Bedürfnisse. Die Ergebnisse lassen sich auf dem Bildschirm betrachten, ausdrucken oder exportieren. Jede gespeicherte Abfrage kann an die DNA-Komponente, auf die sie sich bezieht, angefügt und so jederzeit leicht wieder abgerufen werden.

  1. Wählen Sie {Tools}{Abfragetool} in der Menüleiste.
    Oder
    Klicken Sie auf das Symbol "Abfragetool" in der Symbolleiste.
    Oder
    Klicken Sie, während die Registerkarte "Abfragen" im Konsolefenster ausgewählt ist, auf [image] , um eine neue Abfrage zu erstellen.

Erstellen einer neuen Abfrage

  1. Klicken Sie auf "Neu", um die Eigenschaften einer neuen Abfrage einzugeben.

  2. Wählen Sie in der Liste "Quellfelder" die Objekte, die Sie in die Ausgabe einschließen möchten. Klicken Sie auf [image] , um die einzelnen Objekte ins Fenster "Anzeigefelder" zu übertragen. Sie können alle Felder in einer bestimmten Kategorie übertragen, indem Sie auf [image] klicken.

  3. Ordnen Sie die Anzeigefelder in die Reihenfolge, in der sie erscheinen sollen, indem Sie auf [image] und [image] klicken. Wenn Sie möchten, dass die Ausgabe nach einem bestimmten Feld sortiert wird, wählen Sie das betreffende Objekt und wählen in der Dropdownliste die gewünschten Sortierkriterien.

  4. Sie können die Datenbank nach spezifischen Records abfragen, indem Sie Bedingungen hinzufügen. Wählen Sie das/die Quellfeld(er) und klicken Sie auf [image], um es/sie in das Fenster "Bedingungsfelder" zu übertragen. Das Dialogfeld "Bedingungseditor" wird eingeblendet.

Abfrage ausführen

  1. Wählen Sie im Dialogfeld "Datenbank-Abfragetool" die gewünschte Abfrage in der Dropdownliste "Abfragen".

  2. Klicken Sie auf "Ausführen". Wenn Sie einen Parameter angegeben haben, werden Sie zur Eingabe des gewünschten Wertes aufgefordert.

  3. Die Ergebnisse werden auf dem Bildschirm angezeigt, aber Sie können die Daten auch ausdrucken oder exportieren.

Vorhandene Abfrage bearbeiten

  1. Öffnen Sie über die Optionen {Tools}{Abfragetool} das Dialogfeld "Abfragetool" und wählen Sie in der Dropdownliste eine Abfrage. Oder wählen Sie, während die Registerkarte "Abfragen" im Konsolefenster ausgewählt ist, eine vorhandene Abfrage und klicken auf [image].

  2. Die verknüpften Informationen werden in den Anzeige- und Bedingungsfeldern eingeblendet.

  3. Verwenden Sie die entsprechenden Schaltflächen zum Hinzufügen/Entfernen von Anzeigefeldern/Bedingungen.

  4. Zum Bearbeiten von Namen, Beschreibung und Berichttitel klicken Sie auf "Eigenschaften".

  5. Alle Änderungen werden gespeichert, wenn Sie eine Abfrage ausführen oder auf "OK" klicken.


Tool Benutzer suchen

In NetSupport DNA gibt es das Tool Benutzer suchen, mit dem Sie Clients in der Strukturansicht identifizieren und suchen können. Es wird eine vordefinierte Liste an Suchparametern bereitgestellt oder Sie können Ihre eigenen erstellen.

  1. Wählen Sie {Tools}{Benutzer suchen} in der Menüleiste.
    Oder
    Klicken Sie auf das Symbol "Benutzer suchen" in der Symbolleiste.

  2. Wählen Sie in der Dropdownliste einen vordefinierten Suchtyp und geben Sie einen assoziierten Wert ein, um die Suche einzuschränken. Es lassen sich auch teilweise Informationen eingeben, wenn Sie die genauen Details nicht kennen. Wenn Sie zum Beispiel nach Computernamen suchen, alle Computer die mit Test beginnen. Oder Sie können zusätzliche Suchparameter einschließen, indem Sie auf Details klicken.

  3. Klicken Sie auf "Suchen".

  4. Eine Liste der übereinstimmenden Clients wird eingeblendet.

  5. Wählen Sie den gewünschten Client in der Liste und klicken Sie auf OK.

  6. Der gewählte Client wird nun gesucht und in der Strukturansicht hervorgehoben.

Erstellen von Suchparametern

Wenn Sie die vordefinierten Suchparameter zu stark einschränken, können Sie neue Abfragen erstellen, die zur zukünftigen Verwendung zu der Liste hinzugefügt werden. Zum Beispiel die Suche nach Benutzern, die eine bestimmte Website besucht haben.

  1. Klicken Sie im Dialogfeld "Benutzer suchen" auf Neu.

  2. Erweitern Sie die entsprechende Kategorie in der Strukturansicht Quellfelder, wählen Sie das gewünschte Feld und klicken Sie auf [image].

  3. Das Dialogfeld "Bedingungseditor" wird eingeblendet. Es lassen sich mehrere Bedingungen auswählen.

  4. Klicken Sie auf Speichern als, um die Anfrage zu speichern. Geben Sie einen Namen ein und klicken Sie auf "OK". Die neue Abfrage wird zur Dropdownliste hinzugefügt.

  5. Stellen Sie zum Durchführen der Suche sicher, dass die gewünschte Abfrage in der Dropdownliste ausgewählt ist, geben Sie den assoziierten Parameter ein und klicken Sie auf Suchen. Übereinstimmende Clients werden aufgeführt.

  6. Wählen Sie den gewünschten Client in der Liste und klicken Sie auf OK.

  7. Der gewählte Client wird gesucht und in der Strukturansicht hervorgehoben.


Nachricht senden

Mit dem Nachrichttool können Administratoren eine Nachricht an einen individuellen Client, eine Abteilung oder das gesamte Unternehmen senden. Sie müssen dazu in der Strukturansicht die entsprechende Auswahl treffen.

  1. Wählen Sie in der Strukturansicht einen Client, eine Abteilung oder ein Unternehmen aus.

  2. Klicken Sie mit der rechten Maustaste und wählen Sie Nachricht.
    Oder
    Wählen Sie {Tools}{Nachricht} in der Menüleiste.
    Oder
    Klicken Sie auf das Symbol "Nachricht senden" in der Symbolleiste.

  3. Das Dialogfeld "Nachricht" wird eingeblendet.

  4. Geben Sie die Nachricht ein. Wenn Sie das Unternehmen oder eine Abteilung gewählt haben, markieren Sie Unterabteilungen und PCs einschließen, damit die Nachricht auch an Unterabteilungen auf dieser Strukturebene gesendet wird. Klicken Sie auf "OK", um die Nachricht abzusenden.

  5. Auf den Client PCs wird ein Dialogfeld mit der Nachricht eingeblendet.


Chatten mit Clients

NetSupport DNA ermöglicht das gleichzeitige Chatten mit einer beliebigen Anzahl Clients über ein scrollbares Textfenster.

  1. Markieren Sie in der Strukturansicht einen Client oder eine Clientgruppe.

  2. Klicken Sie mit der rechten Maustaste und wählen Sie Chat
    oder
    Klicken Sie auf das Chatsymbol in der Symbolleiste
    oder
    Wählen Sie in der Menüleiste die Optionen {Tools}{Chat}.

  3. Auf den Konsole- und Client-PCs wird ein Chatfenster eingeblendet, in dem alle in der Chatsitzung eingeschlossenen Clients aufgeführt sind.

  4. Geben Sie den gewünschten Text in das dafür vorgesehene Feld ein und klicken Sie auf "Senden".

  5. Die Nachricht wird auf allen Client PCs eingeblendet. Der Client hat auch die Möglichkeit, Nachrichten zu senden oder die Chatsitzung durch Klicken auf "Schließen" zu verlassen.

  6. Die Konsole kann die Chatsitzung durch Klicken auf "Schließen" beenden.


Fernsteuerung

Je nachdem, welches Pack Sie gekauft haben, bietet NetSupport DNA eine Auswahl von Fernsteuerungslösungen als optionale Zusätze.

DNA Remote Control

Basierend auf der eigenen Fernsteuerungslösung von NetSupport, NetSupport Manager, bietet DNA Remote Control erweiterte Funktionen für die effektive Verwaltung entfernter Arbeitsstationen. Beobachten, teilen oder kontrollieren Sie den Bildschirm, die Maus und die Tastatur von Ziel-PCs, unabhängig von Betriebssystem und Netzwerkprotokoll. Beinhaltet vollständige Nachricht- und Textchatfunktionen, umfassende Sicherheit, Unterstützung mehrerer Plattformen und Desktopintegration.

NetSupport Manager

Oder Sie haben die Möglichkeit, eine vollständige Arbeitskopie von NetSupport Manager zu Ihrem DNA-Kauf hinzuzufügen. Liefert die klassenbeste PC-Fernsteuerung für Unternehmen. Mit seiner globalen Installationsbasis ist NetSupport Manager eine erprobte Lösung für Helpdesk und entfernte Supportbedürfnisse.

Für weitere Informationen besuchen Sie unsere Website, www.netsupportsoftware.com, oder lesen Sie die NetSupport Manager-Dokumentation.

DNA lässt sich auch zur Verwendung einer beliebigen, von einer Drittpartei hergestellten Fernsteuerungsanwendung konfigurieren.

Fernsteuerung konfigurieren

DNA ermöglicht es Administratoren, über das Fernsteuerungstool beliebige Clientcomputer individuell zu betrachten.

  1. Wählen Sie {Tools}{Fernsteuerung konfigurieren} in der Menüleiste.
    Oder
    Klicken Sie auf das Symbol Diesen PC fernsteuern in der Symbolleiste.

  2. Das Dialogfeld "Fernsteuerungseinstellungen" wird eingeblendet. Dieses dient zur Suche der passenden ausführbaren Datei und der Angabe relevanter Befehlsparameter zur Einleitung einer Fernsteuerungssitzung mit dem gewünschten Client PC.

Starten einer Fernsteuerungssitzung

  1. Wählen Sie in der Strukturansicht einen Client aus. Klicken Sie mit der rechten Maustaste und wählen Sie "Fernsteuerung".

  2. Wenn auf dem Ziel-PC die richtige Software installiert ist, erscheint bei der Konsole ein Betrachtungsfenster für den gewählten Client.

Siehe Softwareverteilung, um herauszufinden, wie man ein Paket zur Verteilung an Clients erstellt.


Datenbankwartung

Damit die DNA-Datenbank übersichtlich bleibt, wird empfohlen, dass Sie historische oder unerwünschte Records regelmäßig löschen/archivieren. Mit dem Datenbankwartungsprogramm können Sie überflüssige Daten aus der DNA-Datenbank entfernen, nicht mehr verwendete Client PCs löschen und mit einer Export/Import-Funktion Sicherungskopien wichtiger Daten anfertigen.

Hinweis: Sie können die Anzahl der Konsolebenutzer, die auf diese Funktion Zugriff haben, beschränken, indem Sie beim Erstellen von Konsolebenutzern Bediener- statt Administratorrechte zuweisen.

Daten löschen

Mit dieser Option können Sie aufgrund von einem spezifischen Stichdatum Records aus den DNA-Datenbanktabellen löschen.

  1. Wählen Sie {Tools}{Datenbankverwaltung} in der Menüleiste. Das Datenbank-Wartungsfeld, Registerkarte Daten löschen, wird eingeblendet.

  2. Wählen Sie die Datenbanktabellen, die Sie in den Löschvorgang einschließen möchten.

  3. Wählen Sie das gewünschte Stichdatum. Alle vor dem angegebenen Datum aufgezeichneten Records werden gelöscht.

  4. Klicken Sie auf "Löschen" und bestätigen Sie, dass Sie fortfahren möchten.

  5. Es wird ein Bestätigungsdialogfeld eingeblendet, in dem Sie sehen können, wie viele Records gelöscht wurden.

PCs löschen

Während sich Ihre Installationsbasis verändert, werden Sie u. U. feststellen, dass die Verwaltung von Lizenzstufen schwierig wird, weil die Datenbank Details über Client PCs, die nicht mehr verwendet werden, enthält. Mit dieser Option können Sie PCs löschen und alle damit verknüpften Daten entfernen.

  1. Wählen Sie {Tools}{Datenbankverwaltung} in der Menüleiste.

  2. Wählen Sie die Registerkarte PCs löschen.

  3. Wählen Sie aus der Liste der verfügbaren PCs die PCs, die Sie löschen möchten. Dies kann nur nach individueller PC- oder, wenn mehrere PCs gelöscht werden sollen, auf Abteilungsebene erfolgen.

  4. Klicken Sie auf [image], um die gewählten Objekte zur Liste Diese PCs löschen hinzuzufügen. Individuelle PCs lassen sich aus der Liste entfernen, indem Sie auf [image] klicken. Das ist nützlich, wenn Sie nicht alle PCs in einer Abteilung löschen möchten.

  5. Wenn Sie die Daten nicht permanent verlieren wollen, können Sie die Records in einer Archivdatei speichern. Stellen Sie sicher, dass die Option Daten archivieren markiert ist.

  6. Klicken Sie auf Löschen. Beim Archivieren werden Sie zur Eingabe eines Dateinamens und Speicherorts aufgefordert. Die Daten werden ins Archiv kopiert, aber bleiben gleichzeitig in der Datenbank. Wenn die Archivierung beendet ist, werden Sie gefragt, ob Sie den Löschvorgang fortsetzen möchten.

Daten exportieren

Mit dieser Option lassen sich die Daten in der DNA-Datenbank exportieren. Dies kann für den Fall, dass die Datenbank beschädigt wird, als Sicherungskopie dienen oder die Daten lassen sich in eine andere Datenbank importieren.

  1. Wählen Sie in der Struktur Verfügbare PCs den/die Client(s), von dem/denen Sie Daten exportieren möchten.

  2. Klicken Sie auf [image], um die Daten in das Fenster PCs zum Exportieren zu übertragen.

  3. Heben Sie die Markierung aller Datenkategorien, die Sie nicht einschließen möchten, auf.

  4. Die Menge der exportierten Daten lässt sich durch Anwendung eines Datenfilters noch weiter beschränken.

  5. Geben Sie an, ob zusätzliche Systemdaten eingeschlossen werden sollen, zum Beispiel angepasste Benutzerdetailseiten, Softwarepakete.

  6. Klicken Sie auf "Export", wenn Sie fertig sind. Geben Sie einen Namen für die XML-Datei, die erstellt werden wird, ein. Sie werden zur Eingabe einer passenden Beschreibung aufgefordert. Dies wird dabei helfen, die Daten beim erneuten Import zu identifizieren.

  7. Klicken Sie auf OK. Wenn der Export beendet ist, erscheint eine Bestätigungsmeldung.

Daten importieren

Zum erneuten Import von vorher exportierten Daten.

  1. Klicken Sie auf [image] und suchen Sie nach der gewünschten Exportdatei.

  2. Das Fenster "Details" liefert eine Zusammenfassung des Dateiinhalts.

  3. Klicken Sie auf "Import". Wenn Konflikte zwischen den importierten Daten und bereits vorhandenen Informationen möglich sind, werden Sie zur Durchführung der zu ihrer Behebung nötigen Aktionen aufgefordert.

  4. Wenn der Import beendet ist, erscheint eine Bestätigungsmeldung.


Clientstatus

Mit dem Feature Clientstatus kann ein Konsolebenutzer überprüfen, dass Client PCs eingeschaltet sind. Dies kann bei der Vorbereitung auf eine Softwareverteilung nützlich sein. Informationen lassen sich auf allen Computern, die der DNA-Datenbank bekannt sind, abrufen.

Hinweis: Auf dem PC des Endbenutzers muss eine Wake-on-Lan-Karte installiert und er muss richtig konfiguriert sein. Die DNA Konsole sendet ein Wake-on-Lan-Paket an den Client. Dieses weist die Arbeitsstation zum Einschalten an.

Einschalten von Rechnern

  1. Wählen Sie das gewünschte Unternehmen oder die gewünschte Abteilung in der Strukturansicht.

  2. Wählen Sie in der Menüleiste die Optionen {Tools}{Clientstatus}
    oder
    Klicken Sie mit der rechten Maustaste und wählen Sie "Clientstatus"
    oder
    Klicken Sie auf das Symbol Status der gewählten Clients anzeigen in der Symbolleiste.

  3. Wenn PCs aktuell nicht eingeschaltet sind, werden nur die IP- und MAC-Adressen angezeigt.

  4. Markieren Sie die gewünschten PCs - es lassen sich mehrere Rechner auswählen - und klicken Sie auf Einschalten.


Hardware-Zusatzgeräte

Mit diesem Dialogfeld können Sie ein Register nicht gescannter Hardwaregeräte, zusammen mit ihren verknüpften Eigenschaften, kompilieren. Aufgelistete Objekte lassen sich dann mit Clients oder nicht gescannten Zusatzgeräten verknüpfen.

  1. Sie können beim Hinzufügen von Zusatzgeräten zu einem vorhandenen Datensatz in der Strukturansicht ein neues Gerät erstellen.

    Oder

    Sie können im Voraus eine Liste mit Geräten erstellen. Wählen Sie hierzu in der Menüleiste die Optionen {Tools}{Hardware-Zusatzgeräte}. Diese lassen sich dann zu einem späteren Zeitpunkt anfügen.

Zusatzgerät-Name

Neu

Klicken Sie auf "Neu", um ein Gerät zur Liste hinzuzufügen. Durch Klicken auf die Pfeile können Sie die Liste sortieren.

Bearbeiten

Dient zum Ändern des Namens eines Listenobjekts.

Löschen

Entfernt das Gerät aus der Liste und aus allen Hardwareinventaren, in denen es erscheint.

Optionen

Mehrere Instanzen gestatten

Wenn diese Option markiert ist, können Sie mehrere Instanzen des Geräts mit dem Inventar eines Benutzers verknüpfen. Zum Beispiel zwei digitale Kameras mit verschiedenen Marken-/Modellnummern.

In eigenem Feld anzeigen

Wenn diese Option markiert ist, wird jede Instanz des Geräts in einem neuen Feld auf der Hardwareinventarisierungsseite aufgelistet. Wenn es jedoch mehrere Instanzen desselben Gerätes gibt, empfiehlt es sich u. U., sie im gleichen Feld zusammen zu gruppieren.

Eigenschaften

Sie können die Eigenschaften des neuen Objekts bearbeiten und zusätzliche Objekte mit dem Gerät verknüpfen, je nachdem, wie viele verwandte Informationen Sie aufzeichnen möchten.

Neu

Verknüpft zusätzliche Objekte mit dem Primärgerät. Klicken Sie auf "Neu" und geben Sie den Gerätenamen ein. Je nach der Informationsmenge, die eingegeben werden soll, können Sie ein Feld mit doppelter Breite bereitstellen. Klicken Sie auf "OK".

Mit den Pfeiltasten lassen sich die Geräte in der Reihenfolge anordnen, in der Sie sie auf der Inventarseite anzeigen möchten.

Bearbeiten

Ermöglicht das Bearbeiten der Eigenschaften eines Geräts.

Löschen

Entfernt ein Gerät aus der Liste und aus allen Inventaren, an die es angefügt ist.

Wenn alle Details eingegeben sind, klicken Sie auf "OK".


Hinzufügen von Nicht-Standard-PC beendet

Bevor das neue Objekt zur Strukturansicht hinzugefügt wird, wählen Sie eine der folgenden Optionen:

Hardware-Zusatzgeräte zu diesem PC hinzufügen

Sie können die neue Hardware einfach als alleinstehendes Objekt zur Struktur hinzufügen oder Zusatzgeräte mit ihr verknüpfen und so eine "Mini"-Hardware-Inventarseite für das Gerät erstellen.

Anderen PC erstellen

Ermöglicht die Wiederholung des Prozesses für nicht gescannte Objekte.

Fertig stellen

Fügt das neue Objekt zur Strukturansicht hinzu und bringt Sie ins Hardware-Inventarfenster zurück.

Nicht gescannte Objekte lassen sich in der Strukturansicht leicht identifizieren, da vor jedem von ihnen [image] steht.


Nicht gescannte Geräte hinzufügen

Geben Sie den Namen des PCs/Geräts, der/das hinzugefügt werden soll, ein und wählen Sie die Abteilung, mit der das Objekt verknüpft werden soll. Klicken Sie auf "Weiter".


Konsolenbenutzer erstellen

Wenn die Konsolenkomponente installiert ist, überprüft das Installationsprogramm den Server, um zu sehen, ob bereits mindestens ein Konsolenbenutzer definiert wurde. Wenn nicht, werden Sie zur Erstellung einer Konsolenbenutzeranmeldung aufgefordert. Konsolenbenutzer erhalten Administratorrechte.

Hinweis: Nach der Installation lassen sich entweder mit dem DNA-Datenbank-Assistenten oder über das Konsolenprogramm selbst zusätzliche Konsolenbenutzer hinzufügen

Zur Erstellung der ersten Konsolenbenutzeranmeldung geben Sie einen Namen und ein Kennwort ein und klicken auf Erstellen.

Klicken Sie auf Weiter.


Installation und Setup der Datenbank zur Verwendung

Geben Sie die Adresse/den Namen des SQL Servers ein, auf dem die DNA-Datenbank erstellt werden soll, sowie die Anmeldedetails des Administrators.


Registrieren einer Lizenz

Mit dem DB-Assistenten können Sie Ihre DNA-Lizenzdetails aktualisieren. Zum Beispiel beim Übergang von einer Evaluierungslizenz zu einer vollständigen Verkaufskopie.

Um eine vollständige Lizenz zu registrieren, kopieren Sie die von NetSupport gelieferte Lizenzdatei in einen geeigneten Ordner und geben den Speicherort in das Dialogfeld “Registrierung” ein.

Geben Sie Ihre Lizenznummer ein, wobei die Groß-/Kleinschreibung berücksichtigt wird. Klicken Sie auf “Registrieren”, um die Lizenz zu aktualisieren.

Hinweis: Ein zentraler Aspekt des Alltagsbetriebs von DNA ist die Häufigkeit, mit der der Server Clientcomputer abfragt, um Daten für alle Hauptkomponenten zu sammeln (Evaluierungsstandard = 10 Minuten). Wenn Sie jedoch über eine große Client-Basis verfügen, kann die Anzahl und Häufigkeit der Verbindungen die Leistung auf unerwünschte Weise beeinträchtigen. Um dem entgegenzuwirken, bestimmt DNA bei der Aktivierung einer "Verkaufs"-Version, ob aufgrund der registrierten Anzahl von Benutzerlizenzen ein passenderes Verbindungsintervall benötigt wird. Nach der Installation kann ein Konsolenbediener das Intervall für die einzelnen Komponenten ggf. manuell ändern.


Setup von Administratorbenutzern für den Zugriff auf den DNA-Server

Wenn beim Erstellen des Konsolenbenutzers während der Installation ein Problem aufgetreten ist, können Sie mit dieser Option im Datenbankassistenten neue Konsolenbenutzer erstellen. Konsolenbenutzer erhalten Administratorrechte.

Hinweis: Zusätzliche Konsolenbenutzer können auch über das Konsolenprogramm selbst erstellt werden.


Setup eines NetSupport DNA-Benutzers für den Zugriff auf die Datenbank

Über dieses Dialogfeld können Sie den Benutzernamen und das Kennwort erstellen/ändern, die zum Zugriff auf die DNA-Datenbank im Server verwendet werden. Wenn Sie die vorhandenen Zugriffsdetails verwenden, überprüfen Sie, dass die Details vom SQL-Administrator bereits erstellt wurden.

Hinweis: Es ist besser, keine bereits vorhandene Administratoranmeldung zu verwenden, da dies die Sicherheit anderer Datenbanken auf dem SQL Server gefährden könnte.


Abteilungseigenschaften ändern

Dieses Dialogfeld lässt sich zu folgenden Zwecken verwenden:

  • Allgemeine Eigenschaften der Abteilung ändern;

  • Eine Abteilung mit einem neuen übergeordneten Objekt in der Struktur verknüpfen;

  • Eine Abteilung löschen;

  • Client PCs zwischen Abteilungen verschieben.

  1. Wählen Sie die gewünschte Abteilung in der Strukturansicht.

  2. Klicken Sie mit der rechten Maustaste und wählen Sie "Eigenschaften".

    oder

    Klicken Sie auf das Abteilungssymbol in der Symbolleiste.

    Oder

    Wählen Sie {Bearbeiten}{Abteilungseigenschaften} in der Menüleiste.

Allgemeine Eigenschaften

Der Name, die Beschreibung und die Symbolfarbe der Abteilung lassen sich ggf. ändern.

Übergeordnetes Objekt

Die Abteilung lässt sich innerhalb der Strukturansicht verschieben. Klicken Sie hierzu auf ein neues übergeordnetes Objekt.

Abteilung löschen

Die gewählte Abteilung kann aus der Struktur gelöscht werden, wenn zur Zeit keine Clients mit ihr verknüpft sind.

PCs zuweisen/neu zuweisen

Ermöglicht es Ihnen, Client PCs zwischen Abteilungen zu verschieben.


Erstellen oder Bearbeiten von Anmeldungen für Konsolebediener

Mit diesem Dialogfeld lassen sich zusätzliche Anmeldungen für Konsolebediener erstellen.

  1. Geben Sie den Benutzernamen ein, der gleichzeitig als Anmeldenamen dient, sowie die Kontaktnummer und E-Mail-Adresse des Benutzers, wenn diese bekannt sind.

  2. Sie können vollständige Administratorrechte zuweisen oder den Zugriff durch Auswahl des Bedienerstatus einschränken. Konsultieren Sie die nachfolgende Tabelle.

  3. Klicken Sie auf "OK". Sie werden zur Registrierung eines Benutzerkennworts aufgefordert.

 | Administrator | Bediener
Konsoleneinstellungen bearbeiten | Keine Einschränkung | Nicht verfügbar
Anwendungsgruppen bearbeiten | Keine Einschränkung | Nicht verfügbar
Konsolebediener hinzufügen/bearbeiten/löschen | Keine Einschränkung | Beschränkt verfügbar. Kann nur eigene Benutzerdetails bearbeiten.
Benutzerdetails anpassen | Keine Einschränkung | Nicht verfügbar
Einstellungen für das Internet-/Anwendungsmetering bearbeiten | Keine Einschränkung | Nicht verfügbar
Genehmigte oder eingeschränkte Listen für das Internet-/Anwendungsmetering bearbeiten | Keine Einschränkung | Nicht verfügbar
Software-Verteilungspakete erstellen | Keine Einschränkung | Nicht verfügbar
Softwarepakete anbieten oder verteilen | Keine Einschränkung | Nicht verfügbar
Abteilungen und dynamische Gruppen aus der hierarchischen Strukturansicht löschen | Keine Einschränkung | Nicht verfügbar
Discovery Tool - Deploy von Clients | Keine Einschränkung | Nicht verfügbar
Datenbankwartung | Keine Einschränkung | Nicht verfügbar


Dynamische Gruppen-Editor

Das Editor-Dialogfeld dient in erster Linie zum Erstellen der Bedingung, die bestimmt, welche Clients in eine dynamische Gruppe eingeschlossen werden. Sie können die Eigenschaften einer vorhandenen Gruppe bearbeiten, neue Gruppen erstellen und die Ausgabe von hier ausführen.

  1. Das Dialogfeld lässt sich beim Erstellen einer neuen Gruppe oder dem Bearbeiten eines vorhandenen Objekts starten.

  2. Klicken Sie mit der rechten Maustaste auf den Namen der dynamischen Gruppe in der Strukturansicht und wählen Sie "Eigenschaften". Oder wählen Sie den Gruppennamen und klicken auf das Symbol "Dynamische Gruppeneingenschaften" in der Symbolleiste. Oder wählen Sie {Bearbeiten}{Dynamische Gruppeneingenschaften} in der Menüleiste.

  3. Im Dialogfeld können Sie sehen, welche Gruppe geladen ist. Wählen Sie ggf. in der Dropdownliste eine andere Gruppe aus.

Es sind folgende Optionen verfügbar:

Neu

Dient zum Erstellen einer neuen dynamischen Gruppe.

Eigenschaften

Dient zum Ändern der Eigenschaften einer vorhandenen dynamischen Gruppe.

Neu laden

Hiermit können Sie die gespeicherte Version der Gruppeneigenschaften neu laden, wenn Sie alle vorgenommenen Änderungen ignorieren möchten. Diese Option ist nicht mehr verfügbar, nachdem die Ergebnisse ausgeführt wurden.

Löschen

Dient zum Löschen der aktuell geladenen dynamischen Gruppe.

Ausführen

Dient zum Ausführen der Ergebnisse der aktuell geladenen dynamischen Gruppe. Objekte, welche die angegebene Bedingung erfüllen, sind im Ergebnisfenster aufgeführt. Sie können die Ausgabe ein- oder ausblenden, indem Sie auf die Schaltfläche "Ergebnisse" klicken.

Abbrechen

Hiermit können Sie die Ausführung der Ergebnisse abbrechen.

Speichern

Wenn Sie sich bei der Eingabe der allgemeinen Eigenschaften für die Gruppe zum Erstellen eines Snapshots entschieden haben, d. h. dass alle neuen Clients, welche die Kriterien erfüllen, nicht automatisch zu der Gruppe hinzugefügt werden, können Sie die Clientliste durch Klicken auf "Speichern" aktualisieren.

Angeben der Bedingungsfelder

  1. Wählen Sie in der Strukturansicht der Quellfelder das/die Feld(er), auf dem/denen die Bedingung beruhen soll. Klicken Sie auf [image] , um die Objekte nacheinander in das Fenster "Bedingungsfelder" zu verschieben.

  2. Der Bedingungseditor wird eingeblendet. Es lassen sich mehrere Bedingungen anwenden. Geben Sie sie nacheinander ein und klicken Sie auf "OK".

  3. Klicken Sie auf "Ausführen", um die Ergebnisse abzurufen. Die dynamische Gruppe ist, zusammen mit den Clients, welche die Bedingung erfüllen, in der Konsolestrukturansicht aufgeführt.


Welcome to NetSupport DNA

NetSupport DNA 2.0
Dynamic Network Administration
Copyright© 2004
NetSupport Ltd
Alle Rechte vorbehalten


Neues Paket erstellen

In diesem Dialogfeld können Sie angeben, welche Dateien/Ordner und zusätzlichen Aktionsparameter in das Paket eingeschlossen werden sollen.

  1. Wählen Sie Dateien hinzufügen oder Ordner hinzufügen und suchen Sie die Datei(en), die in ein Paket zur Verteilung integriert werden sollen. Die Datei wird in der Liste "Paketinhalt" eingeblendet.

  2. Markieren Sie das Paket und klicken Sie auf Aktionen, um die gewünschten Parameter/Befehlszeilenanleitungen hinzuzufügen. Diese werden ausgeführt, wenn das verteilte Paket auf Client PCs eintrifft. Es ist auch eine Auswahl an vordefinierten Parametern verfügbar. Klicken Sie auf "OK".

  3. Nachdem Sie die Aktionen eingegeben haben, wird die Schaltfläche Opt. ausführen verfügbar. Entscheiden Sie, ob Sie das Paket über das standardmäßige Verwaltungskonto von DNA oder einen auf Ihrer Domäne vorhandenen Verwaltungsbenutzernamen und Kennwort verteilen möchten.

  4. Wählen Sie "Beim Client sichtbar", wenn Sie dieses Paket zum Anbieten an Clients verfügbar machen möchten (gilt nur für Abteilungen und Unternehmen).

  5. Nach der Installation lassen sich die Paketsetupdateien von dem/den Clientcomputer(n) entfernen. Wählen Sie Dateien nach der Installation löschen.

  6. Klicken Sie auf "OK".

  7. Das Dialogfeld "Paket testen" wird eingeblendet. Bevor Sie das Paket speichern, können Sie seine Zuverlässigkeit testen oder, wenn Sie zufrieden sind, klicken Sie auf "Paket speichern".

  8. Geben Sie einen Namen und eine Beschreibung für das Paket ein und klicken Sie zur Bestätigung auf "Fertig stellen". Das Paket wird verteilungsbereit an den Server gesendet.

Mit der Importfunktion können Sie Pakete zur Bearbeitung vom Server abrufen.


Warehouse auswählen

Mid diesem Dialogfeld können Sie den Clientcomputer auswählen, der als Host für das Verteilungswarehouse fungiert. Es ist am vorteilhaftesten, wenn sich der gewählte Client am gleichen Ort wie die Rechner, die das verteilte Paket empfangen sollen, befindet.

  1. Klicken Sie auf den Dropdownpfeil, um die Strukturansicht Ihres Netzwerks anzuzeigen.

  2. Wählen Sie den Clientcomputer, der als Host für das Verteilungswarehouse fungieren soll.

  3. Klicken Sie auf "OK".


Paket testen

Bevor Sie ein neu erstelltes Paket verteilungsbereit an den Server senden, können Sie seine Zuverlässigkeit auf einem individuellen Client PC testen.

  1. Wählen Sie einen PC in der Struktur. Der aktuelle Status des Rechners wird angezeigt und Sie können daraus ersehen, ob es sich um einen geeigneten Computer für den Empfang des Pakets handelt. Klicken Sie auf "Weiter".

  2. Das Dialogfeld "Paket senden" wird eingeblendet. Hier werden die geplanten Aktionen bestätigt. Klicken Sie auf Start. Das Dialogfeld zeichnet den Fortschritt der Installation auf und bestätigt, ob die Operationen erfolgreich durchgeführt wurden. Klicken Sie auf "Weiter".

  3. Beschließen Sie aufgrund der Testergebnisse Ihre nächsten Handlungen:

    Paket speichern
    Wenn der Test erfolgreich verlaufen ist, speichern Sie das Paket verteilungsbereit im Server ab.

    Bearbeiten des Pakets fortsetzen
    Bringt Sie ins Dialogfeld "Paket erstellen" zurück, wo Sie die Dateien/Aktionen ändern können.

    Paket auf anderem Computer testen
    Wählen Sie einen anderen PC für den Test.


Warehouse-Status

Dieses Dialogfeld zeigt Details der an Warehouse-PCs gelieferten Pakete und deren aktuellen Status an. Sie können sehen, wann das Paket an das Warehouse geliefert wurde, wann es zuletzt genutzt wurde und wie oft es verwendet worden ist.

Es wird der Status Gültiges Paket oder Paket aus Server gelöscht angewendet. Wenn ein Paket aus dem DNA Server gelöscht wurde, befindet es sich im Warehouse und beansprucht Platz auf dem Client PC. Es empfiehlt sich aus organisatorischen Gründen, die Pakete aus dem Warehouse zu löschen.

Gültige Pakete sind immer noch zur Verteilung verfügbar.


DNA Application Packager - Programm erstellen

Die exe-Datei wird nun verteilungsbereit an die Clients erstellt. Wenn Sie eine der gewählten Optionen ändern möchten, klicken Sie auf "Zurück".

Klicken Sie zur Fortsetzung auf "Weiter".


DNA Application Packager - Fertig stellen

Die ausführbare Datei ist nun zur Verteilung an die Clients bereit.

Klicken Sie auf "Fertig stellen".


Hinweise und Tipps zur Verwendung von DNA Application Packager

  • Das Aufzeichnen einer Installation auf einem PC, der mit den Ziel-PCs übereinstimmt, liefert die besten Ergebnisse. Zum Beispiel das Betriebssystem des PCs und die Anzeigetreiber/-einstellungen können das Installationsplayback beeinflussen.

  • Seien Sie beim Aufzeichnen von Installationen mit dem Application Packager vorsichtig, dass Sie keine unnötigen Wahlen treffen/Mausklicks durchführen oder Fokusänderungen auf den Installerbildschirmen vornehmen.

  • Vermeiden Sie beim Playback einer Installation das Liefern/Ausführen des Installers auf dem Desktop. Manche Installationsprogramme blenden unter diesen Bedingungen nämlich zusätzliche Dialogfelder ein.

  • Application Packager unterstützt keine Installationsprogramme, die während der Installation einen Neustart erfordern, aber er lässt sich zum Aufzeichnen von Installationen verwenden, die nach ihrer Beendung einen Neustart erfordern. Beim Aufzeichnen einer Installation werden alle Aufforderungen zum Neustart oder Abmelden des PCs abgelehnt.

  • Anwendungsplayback wird nicht unterstützt, während der Ziel-PC abgemeldet ist.

Unterstützte Befehlszeilenoptionen

Vom Application Packager erstellte automatisch ausführende Installerpakete

========================================================================

/ extract

erstellt ein temporäres Verzeichnis und extrahiert den Inhalt des Pakets. Das extrahierte Installerskript lässt sich mit dem Skripteditor bearbeiten

RecorderScriptPlayback.EXE

==========================

/script scriptName

Name des Skripts für das Playback

/exe exeName

Name der exe, gegen die das Skript abgespielt wird

Ausgangscodes

// extract errors

-100 - keine Dateien in der automatisch generierten exe gefunden

-101 - Fehler beim Extrahieren der Dateien

-102 - Speicherfehler beim Extrahieren der Dateien

-103 - Dekomprimierungsfehler beim Extrahieren der Dateien

-104 - komprimierte Daten beschädigt

-105 - kann keine extrahierte Datei erstellen

-106 - Fehler beim Schreiben der Extrahierungsdatei

-107 - keine Skriptdatei in der exe

-108 - kann kein temp. Verzeichnis zum Extrahieren der eingebetteten Dateien erstellen

// playback errors

-502 - kann Prozess nicht erstellen

-503 - keine Anleitungen in der Skriptdatei

-505 - kein Skriptname gegeben

-506 - Skript existiert nicht

-510 - Skript abgebrochen

-511 - Timeout


Anwendungsgruppenkategorien

Zum Erstellen zusätzlicher Kategorien klicken Sie auf "Neu" und geben den gewünschten Namen ein.


Record für Lieferanten/Händler erstellen

Hier können Sie Details Ihrer Softwarelieferanten hinzufügen oder bearbeiten.

Klicken Sie auf Neu, um einen Händlerrecord zu erstellen.


Lizenzdetails

Geben Sie die gewünschten Lizenzinformationen ein.

Wenn der Softwarelieferant zur Zeit nicht aufgeführt ist, klicken Sie auf [image], um einen neuen Händlerrecord zu erstellen.


License Info

Lizenzinfo

In DNA können Sie für jede Anwendung vollständige Lizenzinformationen festhalten.

Wenn zur Zeit keine Informationen mit der Anwendung verknüpft sind, klicken Sie auf "Neu" und geben die gewünschten Details ein. Um Lizenzinformationen zu ändern, wählen Sie den aktuellen Record und klicken auf "Bearbeiten".


Abfragetool - Dialogfeld "Eigenschaften"

In diesem Dialogfeld können Sie die allgemeinen Eigenschaften der Abfrage eingeben.

Name und Beschreibung

Geben Sie einen sinnvollen Namen und eine Beschreibung für die Abfrage ein. Der Name wird zur Dropdownliste mit Abfragen, aus der Sie bei jedem Laden eines Berichts auswählen können, hinzugefügt.

Berichttitel

Der Titel, welcher der endgültigen Ausgabe beigefügt wird. Zu Flexibilitätszwecken können Sie angeben, dass beim Ablaufen eine veränderliche Bedingung mit dem Format %1, %2, usw. eingegeben werden soll. Die Nutzungsbeschränkungen für diese Funktion finden Sie im nachfolgenden Hinweis.

Anzahl Zeilen zum gleichzeitigen Betrachten

Geben Sie ein, wie viele Records pro Seite gedruckt werden sollen.

Berichtbreite

Im Allgemeinen wird die Ausgabe an die Seite angepasst, aber Sie können eine Zeichenbreite angeben, wenn Ihnen eine andere Anzeigebreite besser gefällt

Nur eindeutige Zeilen anzeigen

Durch Markieren dieser Option können Sie verhindern, dass mehrere Instanzen desselben Records eingeschlossen werden.

Denken Sie daran, welche Ausgabe die Abfrage wahrscheinlich erzeugen wird und beschließen Sie, ob Sie duplizierte Records ausschließen möchten. Alle angezeigten Felder müssen übereinstimmen, damit der Record ignoriert wird. Im nachfolgenden Ausgabebeispiel hat "Test 47" zwar dieselbe Site mehrmals besucht, aber durch die Angabe der aktiven Zeit sind alle Records verschieden. Wenn die aktive Zeit nicht eingeschlossen wäre, würden Sie wahrscheinlich nur eine Instanz jedes Records haben wollen.

Zeilen mit NULL anzeigen\Erste Spalte leeren

Wenn die erste Informationsspalte für einen Record leer ist, können Sie diesen Record ignorieren.

NULLs als leer anzeigen

Leere Felder leer lassen statt sie als NULL anzuzeigen.

An eine Komponente anfügen

Abfragen lassen sich an die spezifischen Komponenten anfügen, auf die sie sich beziehen. Wenn Sie das Fenster der betreffenden Komponente betrachten, sind in der Registerkarte "Abfragen" die angefügten Objekte aufgeführt und Sie erhalten eine Schnellausführoption.

Hinweis: Da es keinen Mechanismus zur Eingabe von Parametern über die Registerkarte "Abfragen" gibt, fügen Sie einer Komponente keine Abfragen hinzu, wenn der Titel eine Variable erfordert. Berichte dieser Art lassen sich nur von der Option "Abfragetool" ausführen.

Klicken Sie auf "OK", um zum Hauptdialogfeld "Abfragetool" zurückzukehren.


Datenbankwartung - Daten importieren

Wenn das System beim Import von Daten mit dem Datenbank-Wartungsprogramm feststellt, dass Konflikte zwischen den importierten Daten und bereits vorhandenen Informationen möglich sind, werden Sie zur Durchführung der nötigen Aktionen aufgefordert.

  • PC Details in der Datenbank überschreiben

  • Kern-PC-Daten belassen - mit Komponentendaten fortsetzen

  • Import aller Daten zu diesem PC überspringen

  • Gewählte Option für alle weiteren PC-Konflikte verwenden


Dialogfeld "Deploy-Optionen"

DNA Server

Bestätigen Sie die Adresse Ihres DNA Servers.

Eingabeaufforderung an Benutzer vor Installationsbeginn

Wenn es wahrscheinlich ist, dass die Ziel-PCs in Betrieb sind, können Sie auf den Clientcomputern eine Warnung einblenden, bevor die Installation beginnt. Die Nachricht lässt sich nur an angemeldete Computer senden.

DNA Winsock Layered Service Provider

Zur Nutzung der Internetblockierungsfunktionen von DNA wird die Aktivierung von LSP empfohlen.

Unter diesen Umständen muss der Clientcomputer zur Beendung der Installation neu gestartet werden. Überlegen Sie auch hier wieder, ob die Computer in Betrieb sind, bevor Sie Ihre Auswahl treffen:

Benutzer zum Neustart des Computers raten

Gibt dem Benutzer die Möglichkeit zum Neustart seines PCs, wenn er das möchte.

Auf Neustart des Computers durch Benutzer beharren

Der Benutzer bekommt 1 Minute Zeit zum Neustart und sonst geschieht dieser automatisch.

Neustart erzwingen

Es wird ein sofortiger Neustart ohne Warnung erzwungen.

Automatischer Neustart, wenn nicht angemeldet

Diese Option lässt sich mit allen der obigen Neustartoptionen einschließen.

Klicken Sie auf "OK", um mit der Verteilung zu beginnen.

Hinweis: Bei der gleichzeitigen Verteilung an über 100 Computer erscheint eine Warnmeldung. Die Verteilung an eine große Anzahl von PCs ist mit potenziellen Overheads verbunden und es kann daher empfehlenswert sein, die Verteilung in mehreren Stadien durchzuführen.


Bedingungseditor

Der Bedingungseditor umfasst Optionen, die für den ausgewählten Feldtyp relevant sind.

Bedingungseditor - Text-/numerisches Feld Bedingungseditor - Datenfeld

Wählen Sie in der Dropdownliste die Bedingung, die beim Abfragen der Datenbank auf der Suche nach Clients, welche die angegebenen Kriterien erfüllen, angewendet werden soll. Die Bedingung lässt sich mit einem genauen Datenwert oder einem Feldnamen vergleichen, oder Sie können einen benutzerdefinierten Wert eingeben.


List Values Dialog

Dialogfeld "Listenwerte"

Beim Erstellen von benutzerdefinierten Registerkarten mit Benutzerdetails können Sie in diesem Dialogfeld gewählte Optionen für ein Dropdownlistenfeld aufführen.

  1. Geben Sie den neuen Wert ein und klicken Sie auf [image], um ihn zum Fenster "Listenwerte" hinzuzufügen. Wiederholen Sie den Vorgang für jede der gewählten Optionen.

  2. Einer der Werte lässt sich als Standardeingabe für das Feld auswählen. Wählen Sie das Objekt und klicken Sie auf [image]. Wenn kein Standardwert zugewiesen ist, wird beim Betrachten durch den Benutzer ein leeres Feld eingeblendet.

  3. Klicken Sie auf "OK", wenn Sie fertig sind.


Editor für benutzerdefinierte Felder - Steuerelemente

Eine benutzerdefinierte Benutzer/Inventar-Registerkarte kann verschiedene Steuerelemente/Eingabefelder beinhalten. Wählen Sie den gewünschten Control, ziehen ihn mit der Drag&&Drop-Funktion an den gewünschten Ort auf der Seite und geben die assoziierten Eigenschaften ein.

Control-Schaltfläche | Zweck | Eigenschaften
 | Dient dazu, Objekte auf der Seite zu verschieben und ihre Größe zu verändern. |
 | Ermöglicht das Hinzufügen der Textbeschreibungen für die einzelnen Eingabefelder. Die Beschreibungen sind auf der Registerkarte als Leitfaden für Benutzer beim Aktualisieren ihrer Details angezeigt, aber im Informationsfenster "Benutzerdetails" auf der Konsole erscheinen sie nicht. | Mit der Drag&&Drop-Funktion an den gewünschten Ort ziehen. Jedes Mal, wenn dieses Steuerelement hinzugefügt wird, erhält es zunächst einmal einen sequenziellen Namen, Text 1, Text 2, usw. Ändern Sie zur Eingabe der gewünschten Feldbeschreibung die Steuereigenschaften. Im Fenster "Eigenschaften" sind zwei Objekte aufgeführt. Der Name des Steuerelements und der aktuell zugewiesene Textwert. Ersetzen Sie den Textwert mit Ihrer eigenen Bezeichnung.
 | Erstellt ein Textfeld, in das Benutzer freien Text eingeben können. Zu Eingabezwecken würden Sie generell neben dem Feld ein Textbeschreibungselement hinzufügen. Im Informationsfenster "Benutzerdetails" an der Konsole kann Beschreibungstext eingegeben werden. | Im Fenster "Eigenschaften" ist diesem Steuerelement der Name Edit 1, Edit 2, usw. zugewiesen. Diese Beschreibung erscheint im Informationsfenster "Benutzerdetails", wenn Sie die Eigenschaften nicht ändern. Ändern Sie den Wert für die Eigenschaft Name auf die gewünschte Bezeichnung. Mit den beiden anderen Eigenschaften, Beim Client deaktivieren und Beim Client dunkel schalten, kann das Feld bei Benutzern ebenfalls ausgeblendet werden, d. h. dass nur Bediener die Details aktualisieren können. Klicken Sie auf den aktuellen Wert. Es wird ein Symbol eingeblendet, in dem Sie "Richtig" oder "Falsch" auswählen können, je nachdem, ob das Feld aktiv sein sollte oder nicht.
 | Gruppenfeld. Nützlich zur Einteilung des Eingabeformulars in offensichtliche Kategorien. Ermöglicht das Zeichnen eines Feldes um eine Feldergruppe und die Anwendung einer Kategorieüberschrift. | Ziehen Sie das Steuerelement an den gewünschten Ort und erweitern Sie das Feld mit den Ziehpunkten auf die gewünschte Größe. Um eine passende Beschreibung hinzuzufügen, ändern Sie den Wert der Texteigenschaft.
 | Kontrollkästchen Es werden im Allgemeinen mehrere solche Steuerelemente verwendet, so dass der Benutzer eine Auswahl an Antworten hat. Zum Beispiel 18-35, 36-50, usw. Benutzer markieren das zutreffende Feld. | Ziehen Sie das Steuerelement mit der Drag&&Drop-Funktion an den gewünschten Ort. Es heißt zunächst einmal Check Box 1, Check Box 2, usw. Um den Namen auf dem Eingabeformular zu ändern, modifizieren Sie die Textwerteigenschaft, um die Beschreibung im Fenster "Benutzerdetails" zu ändern, modifizieren Sie die Namenswerteigenschaft. Dieses Feld lässt sich ggf. beim Client deaktivieren.
 | Bietet eine Antwortauswahl in Form einer Dropdownliste. Sie würden generell neben dem Feld ein Textbeschreibungselement hinzufügen. | Ziehen Sie das Steuerelement mit der Drop-Funktion an den gewünschten Ort. Um im Fenster "Benutzerdetails" eine Beschreibung hinzuzufügen, ändern Sie die Namenswerteigenschaft. Dieses Feld lässt sich ggf. beim Client deaktivieren oder dunkel schalten. Um die Werte für die Dropdownliste einzugeben, klicken Sie auf die Eigenschaft "Listenwerte". Klicken Sie auf das erscheinende Symbol und das Dialogfeld "Listenwerte" wird eingeblendet.
 | Listenfeld Es wird eine Werteliste eingeblendet, in welcher der Benutzer die gewünschte Antwort auswählen kann. Sie würden generell neben dem Feld ein Textbeschreibungselement hinzufügen. | Ziehen Sie das Steuerelement mit der Drop-Funktion an den gewünschten Ort. Um im Fenster "Benutzerdetails" eine Beschreibung hinzuzufügen, ändern Sie die Namenswerteigenschaft. Dieses Feld lässt sich ggf. beim Client deaktivieren oder dunkel schalten. Um die Werte einzugeben, klicken Sie auf die Eigenschaft "Listenwerte". Klicken Sie auf das erscheinende Symbol und das Dialogfeld "Listenwerte" wird eingeblendet.